Bug 845975 - ovirt-engine-backend [TEXT]: Error message when trying to create a disk on a DC which the vm is not on should be fixed
ovirt-engine-backend [TEXT]: Error message when trying to create a disk on a ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
medium Severity medium
: ---
: 3.1.0
Assigned To: Asaf Shakarchi
Gadi Ickowicz
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-06 07:05 EDT by Dafna Ron
Modified: 2016-02-10 11:52 EST (History)
13 users (show)

See Also:
Fixed In Version: SI20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:58:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (228.94 KB, application/x-xz)
2012-08-06 07:05 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-08-06 07:05:05 EDT
Created attachment 602483 [details]
log

Description of problem:

when creating a disk we are able to select a DC that the vm is not located on (vm exists on DC NFS and I am trying to create the disk on DC iSCSI). 

the error backend gives is: 

Cannot add Virtual Machine Disk. The target Data Center does not contain the Virtual Machine Disk.

since I am trying to create the disk I think that its pretty obvious that the disk will not be in the target Data Center :)

we need to remove the work Disk and just leave the virtual machine part. 


Version-Release number of selected component (if applicable):

si13

How reproducible:

100%

Steps to Reproduce:
1. create a vm on one DC
2. create the disk on a second dc 
3.
  
Actual results:

Error is: 
Error while executing action: Cannot add Virtual Machine Disk. The target Data Center does not contain the Virtual Machine Disk.

Expected results:

it should be: 
Error while executing action: Cannot add Virtual Disk. The target Data Center does not contain the Virtual Machine

Additional info: engine log
Comment 1 Itamar Heim 2012-08-06 07:13:46 EDT
1. agree on error for API
2. for GUI - why isn't the bug on not showing irrelevant DCs?
Comment 2 Simon Grinberg 2012-08-06 10:01:47 EDT
(In reply to comment #1)
> 1. agree on error for API
> 2. for GUI - why isn't the bug on not showing irrelevant DCs?

Can this be related to Bug 845977 ?
Comment 3 Ayal Baron 2012-08-08 08:26:36 EDT
You're creating a disk from within the context of a VM and you can change the DC? that sounds like the bug, not the error message (see Itamar's comment #1)
Comment 4 Dafna Ron 2012-08-08 08:32:13 EDT
there should be a UI bug on being able to select a different DC (I think I have seen or even opened it myself on earlier versions) but this should also be blocked with correct message because of API.
Comment 5 Asaf Shakarchi 2012-09-28 10:47:48 EDT
When creating a disk within a VM context, you cannot choose a DC (this field is hidden, DC selection is possible only when adding a disk from the main disks tab 'new' dialog).
Comment 6 Asaf Shakarchi 2012-10-02 20:50:01 EDT
Patch submitted: http://gerrit.ovirt.org/#/c/8319/
Comment 7 Allon Mureinik 2012-10-03 07:24:59 EDT
merged change id I1740658f448d5281b6b406346ae41487f48915ba
Comment 8 Gadi Ickowicz 2012-10-14 11:29:36 EDT
Verified on SI20

rhevm-3.1.0-20.el6ev.noarch

Note You need to log in before you can comment on or make changes to this bug.