Bug 845982 - Cinnamon menu does not work, Menu doesnt show apps, only categories
Cinnamon menu does not work, Menu doesnt show apps, only categories
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cinnamon (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-06 07:44 EDT by Knut J BJuland
Modified: 2012-08-08 04:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-08 04:04:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Knut J BJuland 2012-08-06 07:44:10 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. write firefix in search bar
2.
3.
  
Actual results:
nothing happen

Expected results:
should display firefox

Additional info:
latest version
Comment 1 leigh scott 2012-08-06 08:16:38 EDT
The search in the main menu works as expected here.
Comment 2 Knut J BJuland 2012-08-06 09:52:21 EDT
There might be some trouble with a old config files or old extensions that interfere with cinnamon menus.
Comment 3 Knut J BJuland 2012-08-06 10:35:20 EDT
** FPS for ClutterStage: 8 ***
    JS ERROR: !!!   Exception was: TypeError: parent._vis_iter is undefined
    JS ERROR: !!!     lineNumber = '896'
    JS ERROR: !!!     fileName = '"/usr/share/cinnamon/applets/menu@cinnamon.org/applet.js"'
    JS ERROR: !!!     stack = '"([object _private_St_Button],[object _private_Clutter_Event])@/usr/share/cinnamon/applets/menu@cinnamon.org/applet.js:896
"'
    JS ERROR: !!!     message = '"parent._vis_iter is undefined"'
    JS ERROR: !!!   Exception was: TypeError: parent._vis_iter is undefined
    JS ERROR: !!!     lineNumber = '896'
    JS ERROR: !!!     fileName = '"/usr/share/cinnamon/applets/menu@cinnamon.org/applet.js"'
    JS ERROR: !!!     stack = '"([object _private_St_Button],[object _private_Clutter_Event])@/usr/share/cinnamon/applets/menu@cinnamon.org/applet.js:896
"'
    JS ERROR: !!!     message = '"parent._vis_iter is undefined"'
    JS ERROR: !!!   Exception was: TypeError: parent._vis_iter is undefined
    JS ERROR: !!!     lineNumber = '896'
    JS ERROR: !!!     fileName = '"/usr/share/cinnamon/applets/menu@cinnamon.org/applet.js"'
    JS ERROR: !!!     stack = '"([object _private_St_Button],[object _private_Clutter_Event])@/usr/share/cinnamon/applets/menu@cinnamon.org/applet.js:896
"'
    JS ERROR: !!!     message = '"parent._vis_iter is undefined"'
*** FPS for ClutterStage: 16 ***
    JS ERROR: !!!   Exception was: TypeError: parent._vis_iter is undefined
    JS ERROR: !!!     lineNumber = '896'
    JS ERROR: !!!     fileName = '"/usr/share/cinnamon/applets/menu@cinnamon.org/applet.js"'
    JS ERROR: !!!     stack = '"([object _private_St_Button],[object _private_Clutter_Event])@/usr/share/cinnamon/applets/menu@cinnamon.org/applet.js:896
"'
    JS ERROR: !!!     message = '"parent._vis_iter is undefined"'
*** FPS for ClutterStage: 37 ***
*** FPS for ClutterStage: 5 ***
*** FPS for ClutterStage: 5 ***
    JS ERROR: !!!   Exception in callback for signal: open-state-changed
    JS ERROR: !!!     message = '"this.selectedAppTitle is undefined"'
    JS ERROR: !!!     lineNumber = '791'
    JS ERROR: !!!     fileName = '"/usr/share/cinnamon/applets/menu@cinnamon.org/applet.js"'
    JS ERROR: !!!     stack = '"([object Object],false)@/usr/share/cinnamon/applets/menu@cinnamon.org/applet.js:791
_emit("open-state-changed",false)@/usr/share/gjs-1.0/signals.js:124
(true)@/usr/share/cinnamon/js/ui/popupMenu.js:1245
()@/usr/share/cinnamon/js/ui/popupMenu.js:2016
([object _private_Clutter_Stage],[object _private_Clutter_Event])@/usr/share/cinnamon/js/ui/popupMenu.js:2005
Comment 4 leigh scott 2012-08-06 12:42:22 EDT
Are you using a custom theme?
Comment 5 Knut J BJuland 2012-08-06 16:55:14 EDT
No am using Cinnemon for theme, and Afwaita for windows theme, Cursor theme, Icon theme and gtk+ theme.
Comment 6 Knut J BJuland 2012-08-07 23:23:26 EDT
Hi I found the upstream bug. Menu doesnt show apps, only categories

https://github.com/linuxmint/Cinnamon/issues/981
Comment 7 Knut J BJuland 2012-08-07 23:50:28 EDT
I resolved my trouble by replacing the code for the menu with the latest code from git.
Comment 8 leigh scott 2012-08-08 04:04:16 EDT
(In reply to comment #7)
> I resolved my trouble by replacing the code for the menu with the latest
> code from git.

The fix hasn't even been merged yet so I closing this as not a bug.

https://github.com/linuxmint/Cinnamon/pull/973

Note You need to log in before you can comment on or make changes to this bug.