Bug 846054 - Partial model name matches should work in list.cgi
Partial model name matches should work in list.cgi
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog (Show other bugs)
1.6.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tony Fu
http://hardware.redhat.com/
:
Depends On:
Blocks: 837717
  Show dependency treegraph
 
Reported: 2012-08-06 12:58 EDT by Rob Landry
Modified: 2012-11-15 22:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-15 22:19:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Landry 2012-08-06 12:58:45 EDT
Description of problem:

Searching for 710 does not provide the R710 nor M710 matches.  This also effects HP systems where we've had an L1 say a certified system is not supported because it did not show up.  The change in that case was the dl380p did not show up in the dl380 list.  For whatever reason the 8th generation of the dl380 has a p at the end of it where as the G7 and prior did not.


Additional info:

I think we need to list exact matches first followed by partial matches.  Most likely we need to include vendor make and model in this partial match lookup.
Comment 1 Tony Fu 2012-08-13 04:36:54 EDT
Created attachment 603877 [details]
partial match instead of exact match for vendor/make/model

This patch doesn't address the result order (exactly matched results come first, followed by partially matched results).  If we do need this feature, we probably need to alter the list template code a lot.
Comment 3 Wei Shen 2012-08-13 22:31:26 EDT
Comment on attachment 603877 [details]
partial match instead of exact match for vendor/make/model

Side effect is "Sun 4250" will get nothing, there was another bug which is the opposite of this one.
Comment 4 Wei Shen 2012-08-13 22:39:46 EDT
bug #772219 is the opposite one
Comment 5 Tony Fu 2012-08-20 05:29:00 EDT
Created attachment 605617 [details]
partial match instead of exact match for vendor/make/model

Besides making search by single vendor or make or model work, the new patch makes search by combination of vendor/make/model work as well.  For example, search by 'sun 4250' will return  Sun Netra x4250, Sun Fire X4250, etc.
Comment 6 Rob Landry 2012-08-20 13:49:55 EDT
web2 results look good I think.
Comment 8 Wei Shen 2012-11-01 04:51:14 EDT
verified on web2
Comment 9 Tony Fu 2012-11-15 22:19:57 EST
verified on live system.

Note You need to log in before you can comment on or make changes to this bug.