Bug 846227 - Wrong correlation id in events for deactivate host action
Wrong correlation id in events for deactivate host action
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Juan Hernández
Elena
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-07 04:33 EDT by Elena
Modified: 2016-02-10 14:36 EST (History)
9 users (show)

See Also:
Fixed In Version: si16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:02:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elena 2012-08-07 04:33:10 EDT
When adding Correlation-Id header to deactivate host action request it doesn't returned correcly by related event.

api/hosts/456c4a30-e065-11e1-8552-07ecb740587d/deactivate
headers={'Correlation-Id': 1061}

got in event of this request:
<correlation_id>5fdec853</correlation_id>

For activate host action the corrent correlated id is returned in events.
Comment 1 Juan Hernández 2012-08-22 08:48:58 EDT
The reason for this is that the API uses the MaintananceNumberOfVdss backend command, but this doesn't propagate the correlation id to the MaintananceVds commands that it runs internally. The proposed solution is available here:

http://gerrit.ovirt.org/7412
Comment 2 Juan Hernández 2012-08-23 12:19:19 EDT
The proposed change has been merged upstream:

http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=89bbeb2308405a5e3de4424254ece16e8fee3575
Comment 4 Elena 2012-09-02 05:42:18 EDT
Verified in rhevm-sdk-3.1.0.7-1.el6ev.noarch.rpm

Note You need to log in before you can comment on or make changes to this bug.