Bug 846304 - kmod-nvidia and akmod-nvidia depsolve problems
kmod-nvidia and akmod-nvidia depsolve problems
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kmod (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: kmod development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-07 07:53 EDT by NM
Modified: 2012-08-07 08:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 08:40:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description NM 2012-08-07 07:53:34 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build Identifier: 

# yum install kmod-nvidia
Loaded plugins: auto-update-debuginfo, langpacks, presto, protectbase, refresh-packagekit
0 packages excluded due to repository protections
Resolving Dependencies
--> Running transaction check
---> Package kmod-nvidia.x86_64 1:304.32-2.fc16 will be installed
--> Processing Dependency: kmod-nvidia-3.4.7-1.fc16.x86_64 >= 1:304.32-2.fc16 for package: 1:kmod-nvidia-304.32-2.fc16.x86_64
--> Running transaction check
---> Package kmod-nvidia-3.4.7-1.fc16.x86_64.x86_64 1:295.59-1.fc16 will be updated
---> Package kmod-nvidia-3.4.7-1.fc16.x86_64.x86_64 1:304.32-2.fc16 will be an update
--> Processing Dependency: nvidia-kmod-common >= 1:304.32 for package: 1:kmod-nvidia-3.4.7-1.fc16.x86_64-304.32-2.fc16.x86_64
--> Finished Dependency Resolution
Error: Package: 1:kmod-nvidia-3.4.7-1.fc16.x86_64-304.32-2.fc16.x86_64 (rpmfusion-nonfree-updates)
           Requires: nvidia-kmod-common >= 1:304.32
           Installed: 1:xorg-x11-drv-nvidia-295.59-1.fc16.x86_64 (@rpmfusion-nonfree-updates)
               nvidia-kmod-common = 1:295.59
           Available: 1:xorg-x11-drv-nvidia-285.05.09-1.fc16.x86_64 (rpmfusion-nonfree)
               nvidia-kmod-common = 1:285.05.09
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Reproducible: Always

Steps to Reproduce:
# yum info nvidia-kmod-common
Loaded plugins: auto-update-debuginfo, langpacks, presto, protectbase, refresh-packagekit
0 packages excluded due to repository protections
Error: No matching Packages to list

Actual Results:  
error

Expected Results:  
smooth install
Comment 1 Josh Boyer 2012-08-07 08:40:11 EDT
The kmod component in Fedora bugzilla is for the new module-init-utils replacement.  Fedora does not provide akmod/kmod kernel module packages.  As you will notice in your output, those come from the rpmfusion repository.  You should report your issue to them.

Thank you for using Fedora.
Comment 2 NM 2012-08-07 08:55:10 EDT
Understood, thanks.

Note You need to log in before you can comment on or make changes to this bug.