Bug 846341 - RHEVM portals are not downloading updated version of spice client (cab file) but using existing one.
RHEVM portals are not downloading updated version of spice client (cab file) ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: Einav Cohen
Tomas Dosek
virt
: Regression
: 845533 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-07 09:58 EDT by Marian Krcmarik
Modified: 2015-09-22 09 EDT (History)
9 users (show)

See Also:
Fixed In Version: si14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:05:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Krcmarik 2012-08-07 09:58:16 EDT
Description of problem:
RHEVM portals are not downloading updated version of spice client (cab file) but using existing one even though spice version string is "higher" than version of installed cab file on client machine.
Installed version of cab on Windows client: 5.0.0.10029
Deployed version of cab on RHEVM machine:
# cat /usr/share/spice/SpiceVersion.txt 
5,0,2,4

According to helper dialog, RHEVM portal can see deployed version of cab file "4,4".

Version-Release number of selected component (if applicable):
RHEVM3.1 - si13 with rhevm-spice-client-x64|86-cab-3.1-2.el6 installed.
Windows client with spice-client 5.0.0.10029 installed (from RHEVM3.0).

How reproducible:
Always

Steps to Reproduce:
1. Open webadmin/User portal of RHEVM with versions and pkgs mentioned above.
2. Connect to the any VM through webadmin/User portal from Windows client with spice client already installed from RHEVM3.0 instance.
  
Actual results:
not updated/already installed spice client is started.

Expected results:
spice client should be updated through cab file.

Additional info:
Comment 1 Marian Krcmarik 2012-08-07 10:05:00 EDT
*** Bug 845533 has been marked as a duplicate of this bug. ***
Comment 4 Einav Cohen 2012-08-09 13:35:15 EDT
patch sent upstream: http://gerrit.ovirt.org/#/c/7065/
Comment 8 Tomas Dosek 2012-08-24 05:52:49 EDT
Verified - si15 - spice plugin is properly being updated from webadmin in current version of webadmin.

Note You need to log in before you can comment on or make changes to this bug.