Bug 846401 - Processes in RHEL 5 are started on a processor not defined in their Cpuset
Processes in RHEL 5 are started on a processor not defined in their Cpuset
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.5
Unspecified Linux
high Severity high
: rc
: ---
Assigned To: jtanenba
Red Hat Kernel QE team
:
Depends On:
Blocks: 743405
  Show dependency treegraph
 
Reported: 2012-08-07 12:54 EDT by Christian Huffman
Modified: 2014-03-17 13:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-17 13:18:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Result of /proc/<pid>/status on RHEL5. (856 bytes, application/octet-stream)
2012-08-07 12:55 EDT, Christian Huffman
no flags Details
Result of /proc/<pid>/status on RHEL6. (1017 bytes, application/octet-stream)
2012-08-07 12:55 EDT, Christian Huffman
no flags Details
Cpuset on RHEL5 (20.00 KB, application/x-tar)
2012-08-07 12:56 EDT, Christian Huffman
no flags Details

  None (edit)
Description Christian Huffman 2012-08-07 12:54:06 EDT
Description of problem:
In RHEL 5 processes are added to the appropriate cpuset when created, but are running on a CPU not allowed by that cpuset.

When tested on RHEL 6 all processes are 

Version-Release number of selected component (if applicable):
kernel 2.6.18-194.32.1.el5
RHEL 5.5

How reproducible:
Not certain if this is every process, or only on certain ones.  It has been noticed to occur on java threads.

Steps to Reproduce:
1. Define a cpuset with parameters seen in attached 'cpuset.tar' on the version indicated above.
2. Start a task for use with this cpuset, and examine the current running processor.
  
Actual results:
Task is started with processor 0 instead of one in the defined set.

Expected results:
Task is started with a processor in the same cpuset.

Additional info:
This works as expected in RHEL 6 when using the cpuset filesystem (and not cgroups).

Attaching the cpuset from RHEL 5, and the /proc/<PID>/status from a process running in both RHEL 5 and RHEL 6.
Comment 1 Christian Huffman 2012-08-07 12:55:24 EDT
Created attachment 602800 [details]
Result of /proc/<pid>/status on RHEL5.

Result of /proc/<pid>/status on RHEL5.
Comment 2 Christian Huffman 2012-08-07 12:55:42 EDT
Created attachment 602801 [details]
Result of /proc/<pid>/status on RHEL6.

Result of /proc/<pid>/status on RHEL6.
Comment 3 Christian Huffman 2012-08-07 12:56:03 EDT
Created attachment 602802 [details]
Cpuset on RHEL5

Cpuset on RHEL5
Comment 4 RHEL Product and Program Management 2012-10-30 02:04:48 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2013-07-24 00:14:26 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 7 jtanenba 2014-03-17 13:18:49 EDT
Could not reproduce the error mentioned. It is attached to a closed customer issue.

Note You need to log in before you can comment on or make changes to this bug.