Bug 846491 - SELinux is preventing /usr/lib/nspluginwrapper/npviewer.bin from 'unlink' accesses on the sock_file socket-2581-1804289383.
SELinux is preventing /usr/lib/nspluginwrapper/npviewer.bin from 'unlink' acc...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:20bd8f1485a631f8c8b47ba9edb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-07 19:06 EDT by thonatas
Modified: 2012-08-13 16:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-13 16:04:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description thonatas 2012-08-07 19:06:14 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.0-2.fc17.i686
time:           Ter 07 Ago 2012 19:05:18 AMT

description:
:SELinux is preventing /usr/lib/nspluginwrapper/npviewer.bin from 'unlink' accesses on the sock_file socket-2581-1804289383.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If você acredita que o npviewer.bin deva ser permitido acesso de unlink em socket-2581-1804289383 sock_file  por default.
:Then você precisa reportar este como um erro.
:Você pode gerar um módulo de política local para permitir este acesso.
:Do
:permitir este acesso agora executando:
:# grep npviewer.bin /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:thumb_tmp_t:s0
:Target Objects                socket-2581-1804289383 [ sock_file ]
:Source                        npviewer.bin
:Source Path                   /usr/lib/nspluginwrapper/npviewer.bin
:Port                          <Desconhecido>
:Host                          (removed)
:Source RPM Packages           nspluginwrapper-1.4.4-9.fc17.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-142.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.0-2.fc17.i686 #1
:                              SMP Mon Jul 30 15:41:00 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    Ter 07 Ago 2012 19:02:57 AMT
:Last Seen                     Ter 07 Ago 2012 19:02:57 AMT
:Local ID                      037d883e-2336-4f27-bf19-f959aacd4079
:
:Raw Audit Messages
:type=AVC msg=audit(1344380577.472:104): avc:  denied  { unlink } for  pid=2581 comm="npviewer.bin" name="socket-2581-1804289383" dev="dm-1" ino=263598 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:thumb_tmp_t:s0 tclass=sock_file
:
:
:type=SYSCALL msg=audit(1344380577.472:104): arch=i386 syscall=unlink success=yes exit=0 a0=83f5ef0 a1=bfbd0934 a2=41ea1ff4 a3=83f5ef0 items=0 ppid=1918 pid=2581 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=npviewer.bin exe=/usr/lib/nspluginwrapper/npviewer.bin subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: npviewer.bin,mozilla_plugin_t,thumb_tmp_t,sock_file,unlink
:
:audit2allow
:
:#============= mozilla_plugin_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow mozilla_plugin_t thumb_tmp_t:sock_file unlink;
:
:audit2allow -R
:
:#============= mozilla_plugin_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow mozilla_plugin_t thumb_tmp_t:sock_file unlink;
:
Comment 1 Miroslav Grepl 2012-08-08 06:20:24 EDT
Are you able to reproduce it?
Comment 2 Daniel Walsh 2012-08-13 16:04:36 EDT
Looks like we currently allow this.

:
:#============= mozilla_plugin_t ==============
:#!!!! This avc is allowed in the current policy

Note You need to log in before you can comment on or make changes to this bug.