Bug 846572 - Sometimes can not alter domain when domain has a ruby-1.9 application
Sometimes can not alter domain when domain has a ruby-1.9 application
Status: CLOSED WORKSFORME
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 03:20 EDT by Jianwei Hou
Modified: 2015-05-14 18:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-14 19:13:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
development.log (21.71 KB, text/x-log)
2012-08-08 03:20 EDT, Jianwei Hou
no flags Details

  None (edit)
Description Jianwei Hou 2012-08-08 03:20:09 EDT
Created attachment 602953 [details]
development.log

Description of problem:
Creaet a scalable ruby-1.9 applicaton and then alter namespace, operation fails.

Version-Release number of selected component (if applicable):
on devenv_1948
client rhc-0.97.3-1.el6_3.noarch

How reproducible:
always

Steps to Reproduce:
1.Create a scable ruby-1.9 application
  rhc app create -a rb91s -t ruby-1.9 -s
2.Access app and make sure everything works fine
3.Alter namespace
  rhc domain alter -n 1948d1
  
Actual results:
OpenShift key found at /home/hjw/.ssh/id_rsa.  Reusing...
Problem reported from server. Response code was 500.
Re-run with -d for more information.


Expected results:
namespace should be alterd, and apps should be working well

Additional info:
attached development.log
Comment 1 Jianwei Hou 2012-08-08 06:15:30 EDT
Can't reproduce it now, but strange it happens.
since it is now always reproducible, move it's severity to low
Comment 2 Jianwei Hou 2012-08-08 06:39:50 EDT
(In reply to comment #1)
> Can't reproduce it now, but strange it happens.
> since it is now always reproducible, move it's severity to low

a typo, it is NOT always reproducible, so move it's severity to low
Comment 3 Ram Ranganathan 2012-08-14 19:13:20 EDT
Without the exact error message from mcollective.log, can't tell what the actual error is on update namespace. 

Suspect it is timing related or a timeout if you are not able to reproduce it.

I just ran a script to alter the namespace w/ a scalable ruby-1.9 app for 20 iterations and it didn't fail once. 

If you see it again, please also add the mcollective log (/var/log/mcollective.log) along w/ the broker log and reopen this bug.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.