Bug 846676 - guestfs_launch() hangs with Debian qemu-kvm 1.1.0
guestfs_launch() hangs with Debian qemu-kvm 1.1.0
Status: CLOSED CANTFIX
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 08:01 EDT by noxdafox
Modified: 2013-02-21 04:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:54:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description noxdafox 2012-08-08 08:01:43 EDT
Description of problem:
Yesterday through APT system I updated qemu-kvm package to version: 1.1.0+dfsg-3

Since then, with KVM module loaded, the GuestFS launch routine hangs indefinitely.
Running libguestfs-test-tool doen not prodce any relevant output, it just hangs until the timeout expires with the CPU 100% loaded on kvm process.

Unloading the KVM kernel module solves it.
Reverting to old qemu-kvm package solves it.
With prior qemu-kvm version everything worked fine.

Here's libguestfs-test-tool output:
===== Test starts here =====
TMPDIR=(not set)
library version: 1.18.1
guestfs_get_append: (null)
guestfs_get_attach_method: appliance
guestfs_get_autosync: 1
guestfs_get_direct: 0
guestfs_get_memsize: 500
guestfs_get_network: 0
guestfs_get_path: /usr/lib/guestfs
guestfs_get_pgroup: 0
guestfs_get_qemu: /usr/bin/kvm
guestfs_get_recovery_proc: 1
guestfs_get_selinux: 0
guestfs_get_smp: 1
guestfs_get_trace: 0
guestfs_get_verbose: 1
host_cpu: x86_64
Launching appliance, timeout set to 300 seconds.
libguestfs: [00000ms] febootstrap-supermin-helper --verbose -f checksum '/usr/lib/guestfs/supermin.d' x86_64
supermin helper [00000ms] whitelist = (not specified), host_cpu = x86_64, kernel = (null), initrd = (null), appliance = (null)
supermin helper [00000ms] inputs[0] = /usr/lib/guestfs/supermin.d
checking modpath /lib/modules/3.2.0-3-amd64 is a directory
picked vmlinuz-3.2.0-3-amd64 because modpath /lib/modules/3.2.0-3-amd64 exists
checking modpath /lib/modules/3.2.0-2-amd64 is a directory
picked vmlinuz-3.2.0-2-amd64 because modpath /lib/modules/3.2.0-2-amd64 exists
supermin helper [00000ms] finished creating kernel
supermin helper [00000ms] visiting /usr/lib/guestfs/supermin.d
supermin helper [00000ms] visiting /usr/lib/guestfs/supermin.d/base.img
supermin helper [00000ms] visiting /usr/lib/guestfs/supermin.d/daemon.img
supermin helper [00000ms] visiting /usr/lib/guestfs/supermin.d/hostfiles
supermin helper [00019ms] visiting /usr/lib/guestfs/supermin.d/init.img
supermin helper [00019ms] adding kernel modules
supermin helper [00120ms] finished creating appliance
libguestfs: [00122ms] begin building supermin appliance
libguestfs: [00122ms] run febootstrap-supermin-helper
libguestfs: [00122ms] febootstrap-supermin-helper --verbose -f ext2 /usr/lib/guestfs/supermin.d x86_64 /var/tmp/guestfs.EypUUV/kernel /var/tmp/guestfs.EypUUV/initrd /var/tmp/guestfs.EypUUV/root
supermin helper [00000ms] whitelist = (not specified), host_cpu = x86_64, kernel = /var/tmp/guestfs.EypUUV/kernel, initrd = /var/tmp/guestfs.EypUUV/initrd, appliance = /var/tmp/guestfs.EypUUV/root
supermin helper [00000ms] inputs[0] = /usr/lib/guestfs/supermin.d
checking modpath /lib/modules/3.2.0-3-amd64 is a directory
picked vmlinuz-3.2.0-3-amd64 because modpath /lib/modules/3.2.0-3-amd64 exists
checking modpath /lib/modules/3.2.0-2-amd64 is a directory
picked vmlinuz-3.2.0-2-amd64 because modpath /lib/modules/3.2.0-2-amd64 exists
supermin helper [00000ms] finished creating kernel
supermin helper [01208ms] finished mke2fs
supermin helper [01209ms] visiting /usr/lib/guestfs/supermin.d
supermin helper [01209ms] visiting /usr/lib/guestfs/supermin.d/base.img
supermin helper [01268ms] visiting /usr/lib/guestfs/supermin.d/daemon.img
supermin helper [01272ms] visiting /usr/lib/guestfs/supermin.d/hostfiles
supermin helper [03614ms] visiting /usr/lib/guestfs/supermin.d/init.img
supermin helper [03615ms] adding kernel modules
supermin helper [08757ms] closing ext2 filesystem
supermin helper [08758ms] finished creating appliance
libguestfs: [08882ms] finished building supermin appliance
libguestfs: [08883ms] begin testing qemu features
libguestfs: [08905ms] finished testing qemu features
libguestfs: accept_from_daemon: 0x97e3e0 g->state = 1
[08906ms] /usr/bin/kvm \
    -global virtio-blk-pci.scsi=off \
    -nodefconfig \
    -nodefaults \
    -nographic \
    -drive file=/tmp/libguestfs-test-tool-sda-qtS2hu,format=raw,if=virtio \
    -machine accel=kvm:tcg \
    -m 500 \
    -no-reboot \
    -no-hpet \
    -device virtio-serial \
    -serial stdio \
    -chardev socket,path=/tmp/libguestfsIGmBWH/guestfsd.sock,id=channel0 \
    -device virtserialport,chardev=channel0,name=org.libguestfs.channel.0 \
    -kernel /var/tmp/.guestfs-1000/kernel.8202 \
    -initrd /var/tmp/.guestfs-1000/initrd.8202 \
    -append 'panic=1 console=ttyS0 udevtimeout=300 no_timer_check acpi=off printk.time=1 cgroup_disable=memory selinux=0 guestfs_verbose=1 TERM=xterm ' \
    -drive file=/var/tmp/.guestfs-1000/root.8202,snapshot=on,if=virtio,cache=unsafeAlarm clock



Version-Release number of selected component (if applicable):
1.18.1-1


How reproducible:
Install latest Debian Wheezy version of qemu-kvm
Make sure that both kvm and kvm_intel modules are loaded into the kernel
Run libguestfs-test-tool or guestfs_launch() routine.
Comment 1 Richard W.M. Jones 2012-08-09 03:52:13 EDT
I'd suspect the problem is qemu.

In Fedora we add fixes to whatever qemu upstream spits out (which
is usually broken).  See our git repo here:

http://pkgs.fedoraproject.org/cgit/qemu.git/
Comment 2 Richard W.M. Jones 2012-11-15 11:41:01 EST
I have libguestfs working on Wheezy now.  However you need to
apply some patches, and there are other bugs.  See:

https://www.redhat.com/archives/libguestfs/2012-November/msg00024.html
Comment 3 noxdafox 2013-02-20 09:42:29 EST
Problem seems to be fixed with newer version of qemu (now in Debian Experimental 1.4.0).

Libguestfs 1.20 from Sid seems to be broken with both qemu versions (Wheezy qemu 1.1.2 Experimental qemu 1.4.0)

Here the libguestfs-test-tools output:

     ************************************************************
     *                    IMPORTANT NOTICE
     *
     * When reporting bugs, include the COMPLETE, UNEDITED
     * output below in your bug report.
     *
     ************************************************************
===== Test starts here =====
PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
library version: 1.20.1
guestfs_get_append: (null)
guestfs_get_attach_method: appliance
guestfs_get_autosync: 1
guestfs_get_cachedir: /var/tmp
guestfs_get_direct: 0
guestfs_get_memsize: 500
guestfs_get_network: 0
guestfs_get_path: /usr/lib/guestfs
guestfs_get_pgroup: 0
guestfs_get_qemu: /usr/bin/kvm
guestfs_get_recovery_proc: 1
guestfs_get_selinux: 0
guestfs_get_smp: 1
guestfs_get_tmpdir: /tmp
guestfs_get_trace: 0
guestfs_get_verbose: 1
host_cpu: x86_64
Launching appliance, timeout set to 600 seconds.
libguestfs: command: run: febootstrap-supermin-helper
libguestfs: command: run: \ --verbose
libguestfs: command: run: \ -f checksum
libguestfs: command: run: \ /usr/lib/guestfs/supermin.d
libguestfs: command: run: \ x86_64
supermin helper [00000ms] whitelist = (not specified), host_cpu = x86_64, kernel = (null), initrd = (null), appliance = (null)
supermin helper [00000ms] inputs[0] = /usr/lib/guestfs/supermin.d
checking modpath /lib/modules/3.2.0-4-amd64 is a directory
picked vmlinuz-3.2.0-4-amd64 because modpath /lib/modules/3.2.0-4-amd64 exists
checking modpath /lib/modules/3.2.0-3-amd64 is a directory
picked vmlinuz-3.2.0-3-amd64 because modpath /lib/modules/3.2.0-3-amd64 exists
supermin helper [00000ms] finished creating kernel
supermin helper [00001ms] visiting /usr/lib/guestfs/supermin.d
supermin helper [00001ms] visiting /usr/lib/guestfs/supermin.d/base.img
supermin helper [00001ms] visiting /usr/lib/guestfs/supermin.d/daemon.img
supermin helper [00001ms] visiting /usr/lib/guestfs/supermin.d/hostfiles
supermin helper [00088ms] visiting /usr/lib/guestfs/supermin.d/init.img
supermin helper [00089ms] adding kernel modules
supermin helper [00318ms] finished creating appliance
libguestfs: checksum of existing appliance: 01b9595383c436b3904827c906396be2abd5b73a7e7c8a9957703e752fa1f5c6
libguestfs: [00324ms] begin building supermin appliance
libguestfs: [00325ms] run febootstrap-supermin-helper
libguestfs: command: run: febootstrap-supermin-helper
libguestfs: command: run: \ --verbose
libguestfs: command: run: \ --copy-kernel
libguestfs: command: run: \ -f ext2
libguestfs: command: run: \ /usr/lib/guestfs/supermin.d
libguestfs: command: run: \ x86_64
libguestfs: command: run: \ /var/tmp/guestfs.IBkG3L/kernel
libguestfs: command: run: \ /var/tmp/guestfs.IBkG3L/initrd
libguestfs: command: run: \ /var/tmp/guestfs.IBkG3L/root
febootstrap-supermin-helper: unrecognized option '--copy-kernel'
febootstrap-supermin-helper: build the supermin appliance on the fly

Usage:
  febootstrap-supermin-helper [-options] inputs [...] host_cpu kernel initrd
  febootstrap-supermin-helper -f ext2 inputs [...] host_cpu kernel initrd appliance
  febootstrap-supermin-helper -f checksum inputs [...] host_cpu
  febootstrap-supermin-helper --help
  febootstrap-supermin-helper --version

This script is used by febootstrap to build the supermin appliance
(kernel and initrd output files).  You should NOT need to run this
program directly except if you are debugging tricky supermin
appliance problems.

NB: The kernel and initrd parameters are OUTPUT parameters.  If
those files exist, they are overwritten by the output.

Options:
  --help
       Display this help text and exit.
  -f cpio|ext2|checksum | --format cpio|ext2|checksum
       Specify output format (default: cpio).
  -u user
       The user name or uid the appliance will run as. Use of this
       option requires root privileges.
  -g group
       The group name or gid the appliance will run as. Use of
       this option requires root privileges.
  -k file | --kmods file
       Specify kernel module whitelist.
  --verbose | -v
       Enable verbose messages (give multiple times for more verbosity).
  --version | -V
       Display version number and exit.
libguestfs: error: external command failed, see earlier error messages
libguestfs: command: run: rm
libguestfs: command: run: \ -rf /var/tmp/guestfs.IBkG3L
libguestfs-test-tool: failed to launch appliance
libguestfs: closing guestfs handle 0x25da4d0 (state 0)
libguestfs: command: run: rm
libguestfs: command: run: \ -rf /tmp/libguestfsVAU69b


Same output for both qemu versions.
Comment 4 noxdafox 2013-02-20 09:44:53 EST
Forgot to mention:

KVM is not enabled as I'm running qemu with Debian inside Virtualbox, shouldn't be relevant but just to be more complete :)
Comment 5 Richard W.M. Jones 2013-02-20 09:54:25 EST
Comments 3 & 4 aren't related to the original bug.

(In reply to comment #3)
> febootstrap-supermin-helper: unrecognized option '--copy-kernel'

This means that febootstrap is too old.  Version 3.21 is
required, 3.20 won't work.
Comment 6 noxdafox 2013-02-21 03:40:54 EST
shall I close this bug and open a new one?

I've updated febootstrap fron Debian Sid, the result is that it hangs:

     ************************************************************
     *                    IMPORTANT NOTICE
     *
     * When reporting bugs, include the COMPLETE, UNEDITED
     * output below in your bug report.
     *
     ************************************************************
===== Test starts here =====
PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
library version: 1.20.1
guestfs_get_append: (null)
guestfs_get_attach_method: appliance
guestfs_get_autosync: 1
guestfs_get_cachedir: /var/tmp
guestfs_get_direct: 0
guestfs_get_memsize: 500
guestfs_get_network: 0
guestfs_get_path: /usr/lib/guestfs
guestfs_get_pgroup: 0
guestfs_get_qemu: /usr/bin/kvm
guestfs_get_recovery_proc: 1
guestfs_get_selinux: 0
guestfs_get_smp: 1
guestfs_get_tmpdir: /tmp
guestfs_get_trace: 0
guestfs_get_verbose: 1
host_cpu: x86_64
Launching appliance, timeout set to 600 seconds.
libguestfs: command: run: febootstrap-supermin-helper
libguestfs: command: run: \ --verbose
libguestfs: command: run: \ -f checksum
libguestfs: command: run: \ /usr/lib/guestfs/supermin.d
libguestfs: command: run: \ x86_64
supermin helper [00000ms] whitelist = (not specified), host_cpu = x86_64, kernel = (null), initrd = (null), appliance = (null)
supermin helper [00000ms] inputs[0] = /usr/lib/guestfs/supermin.d
checking modpath /lib/modules/3.2.0-4-amd64 is a directory
picked vmlinuz-3.2.0-4-amd64 because modpath /lib/modules/3.2.0-4-amd64 exists
checking modpath /lib/modules/3.2.0-3-amd64 is a directory
picked vmlinuz-3.2.0-3-amd64 because modpath /lib/modules/3.2.0-3-amd64 exists
supermin helper [00000ms] finished creating kernel
supermin helper [00001ms] visiting /usr/lib/guestfs/supermin.d
supermin helper [00001ms] visiting /usr/lib/guestfs/supermin.d/base.img
supermin helper [00002ms] visiting /usr/lib/guestfs/supermin.d/daemon.img
supermin helper [00002ms] visiting /usr/lib/guestfs/supermin.d/hostfiles
supermin helper [00173ms] visiting /usr/lib/guestfs/supermin.d/init.img
supermin helper [00174ms] adding kernel modules
supermin helper [00294ms] finished creating appliance
libguestfs: checksum of existing appliance: 5865a5198d5acc0cfb09e5d71f71d4767e5e081b5cbc936e47180d8dab2c90f8
libguestfs: [00302ms] begin testing qemu features
libguestfs: command: run: /usr/bin/kvm
libguestfs: command: run: \ -nographic
libguestfs: command: run: \ -help
W: kvm binary is deprecated, please use qemu-system-x86_64 instead
libguestfs: command: run: /usr/bin/kvm
libguestfs: command: run: \ -nographic
libguestfs: command: run: \ -version
W: kvm binary is deprecated, please use qemu-system-x86_64 instead
libguestfs: qemu version 1.4
libguestfs: command: run: /usr/bin/kvm
libguestfs: command: run: \ -nographic
libguestfs: command: run: \ -machine accel=kvm:tcg
libguestfs: command: run: \ -device ?
libguestfs: [00643ms] finished testing qemu features
libguestfs: accept_from_daemon: 0x1bd24d0 g->state = 1
[00646ms] /usr/bin/kvm \
    -global virtio-blk-pci.scsi=off \
    -nodefconfig \
    -nodefaults \
    -nographic \
    -device virtio-scsi-pci,id=scsi \
    -drive file=/tmp/libguestfs-test-tool-sda-u3EL1u,cache=none,format=raw,id=hd0,if=none \
    -device scsi-hd,drive=hd0 \
    -drive file=/var/tmp/.guestfs-1000/root.9953,snapshot=on,id=appliance,if=none,cache=unsafe \
    -device scsi-hd,drive=appliance \
    -machine accel=kvm:tcg \
    -m 500 \
    -no-reboot \
    -no-hpet \
    -device virtio-serial \
    -serial stdio \
    -device sga \
    -chardev socket,path=/tmp/libguestfsLD0ec6/guestfsd.sock,id=channel0 \
    -device virtserialport,chardev=channel0,name=org.libguestfs.channel.0 \
    -kernel /var/tmp/.guestfs-1000/kernel.9953 \
    -initrd /var/tmp/.guestfs-1000/initrd.9953 \
    -append 'panic=1 console=ttyS0 udevtimeout=600 no_timer_check acpi=off printk.time=1 cgroup_disable=memory root=/dev/sdb selinux=0 guestfs_verbose=1 TERM=xterm'W: kvm binary is deprecated, please use qemu-system-x86_64 instead
Could not access KVM kernel module: No such file or directory
failed to initialize KVM: No such file or directory
Back to tcg accelerator.
Could not open option rom 'sgabios.bin': No such file or directory
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Linux version 3.2.0-4-amd64 (debian-kernel@lists.debian.org) (gcc version 4.6.3 (Debian 4.6.3-14) ) #1 SMP Debian 3.2.35-2
[    0.000000] Command line: panic=1 console=ttyS0 udevtimeout=600 no_timer_check acpi=off printk.time=1 cgroup_disable=memory root=/dev/sdb selinux=0 guestfs_verbose=1 TERM=xterm
[    0.000000] BIOS-provided physical RAM map:
[    0.000000]  BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
[    0.000000]  BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
[    0.000000]  BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
[    0.000000]  BIOS-e820: 0000000000100000 - 000000001f3fe000 (usable)
[    0.000000]  BIOS-e820: 000000001f3fe000 - 000000001f400000 (reserved)
[    0.000000]  BIOS-e820: 00000000fffc0000 - 0000000100000000 (reserved)
[    0.000000] NX (Execute Disable) protection: active
[    0.000000] DMI 2.4 present.
[    0.000000] No AGP bridge found
[    0.000000] last_pfn = 0x1f3fe max_arch_pfn = 0x400000000
[    0.000000] x86 PAT enabled: cpu 0, old 0x7040600070406, new 0x7010600070106
[    0.000000] found SMP MP-table at [ffff8800000fdb00] fdb00
[    0.000000] init_memory_mapping: 0000000000000000-000000001f3fe000
[    0.000000] RAMDISK: 1f13d000 - 1f3f0000
[    0.000000] No NUMA configuration found
[    0.000000] Faking a node at 0000000000000000-000000001f3fe000
[    0.000000] Initmem setup node 0 0000000000000000-000000001f3fe000
[    0.000000]   NODE_DATA [000000001f3f6000 - 000000001f3fafff]
[    0.000000] Zone PFN ranges:
[    0.000000]   DMA      0x00000010 -> 0x00001000
[    0.000000]   DMA32    0x00001000 -> 0x00100000
[    0.000000]   Normal   empty
[    0.000000] Movable zone start PFN for each node
[    0.000000] early_node_map[2] active PFN ranges
[    0.000000]     0: 0x00000010 -> 0x0000009f
[    0.000000]     0: 0x00000100 -> 0x0001f3fe
[    0.000000] SFI: Simple Firmware Interface v0.81 http://simplefirmware.org
[    0.000000] Intel MultiProcessor Specification v1.4
[    0.000000] MPTABLE: OEM ID: BOCHSCPU
[    0.000000] MPTABLE: Product ID: 0.1         
[    0.000000] MPTABLE: APIC at: 0xFEE00000
[    0.000000] Processor #0 (Bootup-CPU)
[    0.000000] IOAPIC[0]: apic_id 0, version 17, address 0xfec00000, GSI 0-23
[    0.000000] Processors: 1
[    0.000000] SMP: Allowing 1 CPUs, 0 hotplug CPUs
[    0.000000] PM: Registered nosave memory: 000000000009f000 - 00000000000a0000
[    0.000000] PM: Registered nosave memory: 00000000000a0000 - 00000000000f0000
[    0.000000] PM: Registered nosave memory: 00000000000f0000 - 0000000000100000
[    0.000000] Allocating PCI resources starting at 1f400000 (gap: 1f400000:e0bc0000)
[    0.000000] Booting paravirtualized kernel on bare hardware
[    0.000000] setup_percpu: NR_CPUS:512 nr_cpumask_bits:512 nr_cpu_ids:1 nr_node_ids:1
[    0.000000] PERCPU: Embedded 28 pages/cpu @ffff88001ee00000 s82880 r8192 d23616 u2097152
[    0.000000] Built 1 zonelists in Node order, mobility grouping on.  Total pages: 126130
[    0.000000] Policy zone: DMA32
[    0.000000] Kernel command line: panic=1 console=ttyS0 udevtimeout=600 no_timer_check acpi=off printk.time=1 cgroup_disable=memory root=/dev/sdb selinux=0 guestfs_verbose=1 TERM=xterm
[    0.000000] Disabling memory control group subsystem
[    0.000000] PID hash table entries: 2048 (order: 2, 16384 bytes)
[    0.000000] Checking aperture...
[    0.000000] No AGP bridge found
[    0.000000] Memory: 491976k/511992k available (3418k kernel code, 452k absent, 19564k reserved, 3319k data, 576k init)
[    0.000000] Hierarchical RCU implementation.
[    0.000000] \tRCU dyntick-idle grace-period acceleration is enabled.
[    0.000000] NR_IRQS:33024 nr_irqs:256 16
[    0.000000] Console: colour *CGA 80x25
[    0.000000] console [ttyS0] enabled
[    0.000000] Fast TSC calibration failed
[    0.000000] TSC: Unable to calibrate against PIT
[    0.000000] TSC: No reference (HPET/PMTIMER) available
[    0.000000] Marking TSC unstable due to could not calculate TSC khz
[    0.044002] Calibrating delay loop... 23.42 BogoMIPS (lpj=46848)
[    0.084004] pid_max: default: 32768 minimum: 301
[    0.100005] Security Framework initialized
[    0.108005] AppArmor: AppArmor disabled by boot time parameter
[    0.120006] Dentry cache hash table entries: 65536 (order: 7, 524288 bytes)
[    0.128007] Inode-cache hash table entries: 32768 (order: 6, 262144 bytes)
[    0.140008] Mount-cache hash table entries: 256
[    0.172010] Initializing cgroup subsys cpuacct
[    0.180010] Initializing cgroup subsys memory
[    0.184010] Initializing cgroup subsys devices
[    0.188011] Initializing cgroup subsys freezer
[    0.192011] Initializing cgroup subsys net_cls
[    0.196011] Initializing cgroup subsys blkio
[    0.200011] Initializing cgroup subsys perf_event
[    0.208012] mce: CPU supports 10 MCE banks
[    0.224013] SMP alternatives: switching to UP code
[    0.680041] Freeing SMP alternatives: 8k freed
[    0.748046] ------------[ cut here ]------------
[    0.752046] WARNING: at /build/buildd-linux_3.2.35-2-amd64-v9djlH/linux-3.2.35/arch/x86/kernel/apic/apic.c:1318 setup_local_APIC+0x150/0x20a()
[    0.756046] Hardware name: Bochs
[    0.760046] Modules linked in:
[    0.764047] Pid: 1, comm: swapper/0 Not tainted 3.2.0-4-amd64 #1 Debian 3.2.35-2
[    0.768047] Call Trace:
[    0.768047]  [<ffffffff81046a75>] ? warn_slowpath_common+0x78/0x8c
[    0.772047]  [<ffffffff8133f9a9>] ? setup_local_APIC+0x150/0x20a
[    0.776047]  [<ffffffff816b6e65>] ? native_smp_prepare_cpus+0x24f/0x2f2
[    0.776047]  [<ffffffff816abbbd>] ? kernel_init+0x7f/0x152
[    0.776047]  [<ffffffff81354174>] ? kernel_thread_helper+0x4/0x10
[    0.780048]  [<ffffffff816abb3e>] ? start_kernel+0x3be/0x3be
[    0.784048]  [<ffffffff81354170>] ? gs_change+0x13/0x13
[    0.796049] ---[ end trace 838b17af79cced76 ]---
[    0.816050] ..TIMER: vector=0x30 apic1=0 pin1=2 apic2=-1 pin2=-1
[    0.820050] CPU0: AMD QEMU Virtual CPU version 1.4.0 stepping 03
[    0.940058] Performance Events: Broken PMU hardware detected, using software events only.
[    0.968059] NMI watchdog disabled (cpu0): hardware events not enabled
[    0.976060] Brought up 1 CPUs
[    0.980060] Total of 1 processors activated (23.42 BogoMIPS).
[    1.056065] devtmpfs: initialized
[    1.200074] print_constraints: dummy: 
[    1.212075] NET: Registered protocol family 16
[    1.236076] PCI: Using configuration type 1 for base access
[    1.296080] bio: create slab <bio-0> at 0
[    1.308081] ACPI: Interpreter disabled.
[    1.324082] vgaarb: loaded
[    1.332082] PCI: Probing PCI hardware
[    1.364084] pci 0000:00:01.3: quirk: [io  0xb000-0xb03f] claimed by PIIX4 ACPI
[    1.368084] pci 0000:00:01.3: quirk: [io  0xb100-0xb10f] claimed by PIIX4 SMB
[    1.456090] pci 0000:00:01.0: PIIX/ICH IRQ router [8086:7000]
[    1.688104] pnp: PnP ACPI: disabled
[    1.836114] NET: Registered protocol family 2
[    1.844114] IP route cache hash table entries: 4096 (order: 3, 32768 bytes)
[    1.868116] TCP established hash table entries: 16384 (order: 6, 262144 bytes)
[    1.876116] TCP bind hash table entries: 16384 (order: 6, 262144 bytes)
[    1.884117] TCP: Hash tables configured (established 16384 bind 16384)
[    1.888117] TCP reno registered
[    1.888117] UDP hash table entries: 256 (order: 1, 8192 bytes)
[    1.892117] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes)
[    1.904118] NET: Registered protocol family 1
[    1.908118] pci 0000:00:00.0: Limiting direct PCI/PCI transfers
[    1.912118] pci 0000:00:01.0: PIIX3: Enabling Passive Release
[    1.916119] pci 0000:00:01.0: Activating ISA DMA hang workarounds
[    1.932120] Unpacking initramfs...
[    2.052127] Freeing initrd memory: 2764k freed
[    2.076129] platform rtc_cmos: registered platform RTC device (no PNP device found)
[    2.108131] audit: initializing netlink socket (disabled)
[    2.116131] type=2000 audit(1361435867.112:1): initialized
[    2.352146] HugeTLB registered 2 MB page size, pre-allocated 0 pages
[    2.368147] VFS: Disk quotas dquot_6.5.2
[    2.372147] Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
[    2.380148] msgmni has been set to 966
[    2.404149] alg: No test for stdrng (krng)
[    2.408149] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[    2.408149] io scheduler noop registered
[    2.412150] io scheduler deadline registered
[    2.416150] io scheduler cfq registered (default)
[    2.420150] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[    2.428151] pciehp: PCI Express Hot Plug Controller Driver version: 0.4
[    2.432151] acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
[    2.444152] Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
[    2.456152] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[    2.476154] Linux agpgart interface v0.103
[    2.480154] i8042: PNP: No PS/2 controller found. Probing ports directly.
[    2.492155] serio: i8042 KBD port at 0x60,0x64 irq 1
[    2.496155] serio: i8042 AUX port at 0x60,0x64 irq 12
[    2.508156] mousedev: PS/2 mouse device common for all mice
[    2.524157] rtc_cmos rtc_cmos: rtc core: registered rtc_cmos as rtc0
[    2.532157] rtc0: alarms up to one day, 114 bytes nvram
[    2.536157] cpuidle: using governor ladder
[    2.536157] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input0
[    2.540158] cpuidle: using governor menu
[    2.556159] TCP cubic registered
[    2.556159] NET: Registered protocol family 10
[    2.584160] Mobile IPv6
[    2.584160] NET: Registered protocol family 17
[    2.588161] Registering the dns_resolver key type
[    2.600161] registered taskstats version 1
[    2.608162] rtc_cmos rtc_cmos: setting system clock to 2013-02-21 08:37:49 UTC (1361435869)
[    2.612162] Initializing network drop monitor service
[    2.660165] Freeing unused kernel memory: 576k freed
[    2.696167] Write protecting the kernel read-only data: 6144k
[    2.944183] Freeing unused kernel memory: 660k freed
[    3.200199] Freeing unused kernel memory: 680k freed
febootstrap: mounting /proc
febootstrap: uptime: 3.34 0.71
febootstrap: ext2 mini initrd starting up: 3.21
febootstrap: cmdline: panic=1 console=ttyS0 udevtimeout=600 no_timer_check acpi=off printk.time=1 cgroup_disable=memory root=/dev/sdb selinux=0 guestfs_verbose=1 TERM=xterm
febootstrap: mounting /sys
febootstrap: internal insmod libcrc32c.ko
insmod: init_module: libcrc32c.ko: Unknown symbol in module
febootstrap: internal insmod crc32c-intel.ko
insmod: init_module: crc32c-intel.ko: No such device
febootstrap: internal insmod crc16.ko
febootstrap: internal insmod crc-itu-t.ko
febootstrap: internal insmod crc32c.ko
febootstrap: internal insmod crc-ccitt.ko
febootstrap: internal insmod crc7.ko
febootstrap: internal insmod crc8.ko
febootstrap: internal insmod crc-t10dif.ko
febootstrap: internal insmod mbcache.ko
febootstrap: internal insmod scsi_mod.ko
[    3.616225] SCSI subsystem initialized
febootstrap: internal insmod cdrom.ko
febootstrap: internal insmod sr_mod.ko
febootstrap: internal insmod libata.ko
febootstrap: internal insmod ata_piix.ko
[    3.744233] scsi0 : ata_piix
[    3.752233] scsi1 : ata_piix
[    3.756234] ata1: PATA max MWDMA2 cmd 0x1f0 ctl 0x3f6 bmdma 0xc060 irq 14
[    3.760234] ata2: PATA max MWDMA2 cmd 0x170 ctl 0x376 bmdma 0xc068 irq 15
febootstrap: internal insmod scsi_transport_spi.ko
febootstrap: internal insmod sym53c8xx.ko
febootstrap: internal insmod sd_mod.ko
febootstrap: internal insmod rfkill.ko
febootstrap: internal insmod sparse-keymap.ko
febootstrap: internal insmod ideapad-laptop.ko
insmod: init_module: ideapad-laptop.ko: No such device
febootstrap: internal insmod virtio.ko
febootstrap: internal insmod virtio_ring.ko
febootstrap: internal insmod virtio_console.ko
febootstrap: internal insmod rng-core.ko
febootstrap: internal insmod virtio-rng.ko
febootstrap: internal insmod virtio_blk.ko
febootstrap: internal insmod virtio_net.ko
febootstrap: internal insmod virtio_pci.ko
[    4.208262] virtio-pci 0000:00:02.0: PCI->APIC IRQ transform: INT A -> IRQ 34
[    4.224263] virtio-pci 0000:00:03.0: PCI->APIC IRQ transform: INT A -> IRQ 35
febootstrap: internal insmod virtio_balloon.ko
febootstrap: internal insmod jbd2.ko
febootstrap: internal insmod ext4.ko
febootstrap: internal insmod ext2.ko

Trying with qemu 1.4.0.
Comment 7 noxdafox 2013-02-21 03:48:50 EST
The log was incomplete, I apology for that, here the rest of it:

febootstrap: no ext2 root device found
Please include FULL verbose output in your bug report.
[  528.945056] Kernel panic - not syncing: Attempted to kill init!
[  528.945056] Pid: 1, comm: init Tainted: G        W    3.2.0-4-amd64 #1 Debian 3.2.35-2
[  528.945056] Call Trace:
[  528.945056]  [<ffffffff813467bc>] ? panic+0x95/0x1a5
[  528.949056]  [<ffffffff81049b14>] ? do_exit+0x95/0x713
[  528.949056]  [<ffffffff8104a412>] ? do_group_exit+0x74/0x9e
[  528.949056]  [<ffffffff8104a44c>] ? sys_exit_group+0x10/0x10
[  528.949056]  [<ffffffff81352012>] ? system_call_fastpath+0x16/0x1b
[  528.949056] Rebooting in 1 seconds..libguestfs: child_cleanup: 0x1bd24d0: child process died
libguestfs: sending SIGTERM to process 9962
libguestfs: error: guestfs_launch failed, see earlier error messages
libguestfs-test-tool: failed to launch appliance
libguestfs: closing guestfs handle 0x1bd24d0 (state 0)
libguestfs: command: run: rm
libguestfs: command: run: \ -rf /tmp/libguestfsLD0ec6
Comment 8 Richard W.M. Jones 2013-02-21 04:52:00 EST
Please open new bugs for new issues.  If they are duplicate
we will mark them as such.
Comment 9 Richard W.M. Jones 2013-02-21 04:54:03 EST
Closing, since all the issues are fixed if you
follow the instructions here:
https://www.redhat.com/archives/libguestfs/2012-November/msg00024.html
This can't be fixed in libguestfs -- it needs Debian
packaging fixes.

Note You need to log in before you can comment on or make changes to this bug.