Bug 846695 - RHEVM - Admin GUI: Add Virtual Disk dialog presents irrelevant Use Hosts and DCs
RHEVM - Admin GUI: Add Virtual Disk dialog presents irrelevant Use Hosts and DCs
Status: CLOSED DUPLICATE of bug 841191
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.1.0
Assigned To: Einav Cohen
Pavel Stehlik
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 08:58 EDT by Daniel Paikov
Modified: 2016-02-10 11:54 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-08 12:01:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Paikov 2012-08-08 08:58:10 EDT
Disks -> Add -> External (Direct Lun) -> GUI presents in the Use Host drop-down hosts that aren't in Up status and therefore can't be used as Use Host (Maintenance, Non Responsive, etc). When these hosts are selected, getDeviceList is sent to the host even though it isn't available, which causes unnecessary "error 503" pop-ups to be shown in the GUI.
Comment 1 Daniel Paikov 2012-08-08 09:39:10 EDT
Also, this dialog should only present DCs that are iSCSI or FCP. Currently it presents all DCs without filtering anything out.
Comment 2 Simon Grinberg 2012-08-08 11:50:27 EDT
(In reply to comment #1)
> Also, this dialog should only present DCs that are iSCSI or FCP. Currently
> it presents all DCs without filtering anything out.

That is not correct, direct LUN may be used in any DC type since it does not have to join a storage domain. 

The pm_ack is only for the issue raised in comment #0
Comment 3 Haim 2012-08-08 12:01:14 EDT

*** This bug has been marked as a duplicate of bug 841191 ***

Note You need to log in before you can comment on or make changes to this bug.