Bug 846765 - webadmin: please remove hsm from host selection during extend storage domain (connectStorageServer is not sent prior to getDeviceList)
webadmin: please remove hsm from host selection during extend storage domain ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
medium Severity high
: ---
: 3.1.0
Assigned To: Daniel Erez
Dafna Ron
storage
: Regression
: 752845 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 11:51 EDT by Dafna Ron
Modified: 2016-02-10 15:24 EST (History)
12 users (show)

See Also:
Fixed In Version: SI18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (800.89 KB, application/x-gzip)
2012-08-08 11:51 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-08-08 11:51:03 EDT
Created attachment 603064 [details]
logs

Description of problem:

create and extend domains are an spm action and action will fail if we select spm
please remove the other hosts from selection since they cannot perform the action and user will get CanDoAction from backend

Version-Release number of selected component (if applicable):

si13.2

How reproducible:

100%

Steps to Reproduce:
1. extend a domain from hsm host. 
2.
3.
  
Actual results:

we are able to send the command through spm host

Expected results:

since hsm host cannot create or extend a domain we should not be able to select them on the roller (in my case when I open the dialogue the host  

Additional info:
Comment 2 Haim 2012-08-08 12:08:06 EDT
> Actual results:
> 
> we are able to send the command through spm host
> 
> Expected results:
> 
> since hsm host cannot create or extend a domain we should not be able to
> select them on the roller (in my case when I open the dialogue the host  
> 
> Additional info:

this is partially true, hsm can be used to create storage domain, the extend should only happen from spm host, in any-case, the problem here is with ConnectAllHostToStorageDomain command, engine doesn't send connectStorageServer to second host, but only getDeviceList, since new devices doesn't appear in the return, it fails on canDoAction
Comment 3 Simon Grinberg 2012-08-08 12:46:36 EDT
(In reply to comment #2)
> this is partially true, hsm can be used to create storage domain, the extend
> should only happen from spm host, in any-case, the problem here is with
> ConnectAllHostToStorageDomain command, engine doesn't send
> connectStorageServer to second host, but only getDeviceList, since new
> devices doesn't appear in the return, it fails on canDoAction

Does not matter, to preserve consistency with 3.0, only SPM should be used on extend.
Comment 4 Haim 2012-08-08 12:50:50 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > this is partially true, hsm can be used to create storage domain, the extend
> > should only happen from spm host, in any-case, the problem here is with
> > ConnectAllHostToStorageDomain command, engine doesn't send
> > connectStorageServer to second host, but only getDeviceList, since new
> > devices doesn't appear in the return, it fails on canDoAction
> 
> Does not matter, to preserve consistency with 3.0, only SPM should be used
> on extend.

its not a question of who performs the extend (not arguing on that, its spm for sure), engine checks that all hosts see the new luns before its actually sends the extend command, in that case it fails since it lacks the connectStorageServer.
Comment 5 Ayal Baron 2012-08-28 07:11:39 EDT
Dafna, which host is selected by default by GUI?

wrt problem -
indeed ConnectAllHostsToLunCommand assumes for some reason that the host used to get the list initially is the spm and then has a lot of code to avoid connecting to the spm.

Fix should be:
1. GUI should indeed not show the hosts list and just use SPM
2. Code needs to be fixed to not have special handling for spm seeing as it is racy and redundant (if spm changes hosts between initial getDeviceList and rest of the operation then this would fail).
Simplifying the code would solve both issues at the expense of having 1 more connectVDSToStorage (it doesn't even avoid an additional getDeviceList as it is specifically called on the spm today).
Comment 6 Dafna Ron 2012-09-02 03:02:06 EDT
the reason I encountered this issue is because the selection was alphabetical and the hsm was selected instead of the spm.
Comment 7 Allon Mureinik 2012-09-10 12:40:06 EDT
merged change id: Ie5a87c07197e1297c30ef346caea3293304b4452
Comment 8 Dafna Ron 2012-09-21 04:46:01 EDT
verified on si18
only spm is selected on expand and we cannot select a different host
Comment 9 Daniel Erez 2012-09-24 13:56:08 EDT
*** Bug 752845 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.