Bug 846774 - webadmin: we are getting connected devices from cache when trying to extend a domain which show connected devices which are no longer connected in vds
webadmin: we are getting connected devices from cache when trying to extend a...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
medium Severity high
: ---
: 3.1.0
Assigned To: Asaf Shakarchi
Haim
storage
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 12:21 EDT by Dafna Ron
Modified: 2016-02-10 13:28 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-27 14:18:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs and screen shot (458.62 KB, application/x-gzip)
2012-08-08 12:21 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-08-08 12:21:03 EDT
Created attachment 603070 [details]
logs and screen shot

Description of problem:

I logged in to the device -> disconnected the device in vdsm using iscsiadm. 
reopen of the dialogue in UI shows the device connected even though its not connected in vds. 
so we are apparently reading logged in devices from the cache. 
even after I discovered domains again I still see the device logged in. 

Version-Release number of selected component (if applicable):

si13.2

How reproducible:

100%

Steps to Reproduce:
1. log in to several devices through the UI. 
2. in the host use iscsiadm to disconnected on of the devices. 
3. go back to the UI -> try to extend a domain -> device is still shown as connected
4. discover luns again -> device is still shown as connected
5. select lun and extend
  
Actual results:

we would fail extend since the device is no longer connected in the vds so it looks like we are reading from cache and not refreshing UI results. 

Expected results:

we should refresh UI results. 

Additional info: device is Dafna-extend-02

[root@gold-vdsd ~]# iscsiadm -m session
tcp: [14] 10.35.64.10:3260,1 Dafna-si13-01
tcp: [17] 10.35.64.10:3260,1 Dafna-si13-02
tcp: [18] 10.35.64.10:3260,1 Dafna-si13-03
tcp: [19] 10.35.64.10:3260,1 Dafna-extend-01
Comment 1 Asaf Shakarchi 2012-10-11 09:09:23 EDT
I logged in to 25-30 targets, after disconnecting the targets on the host, re-opening the dialog shows only the targets the with luns that the domain is attached to, closing.
Comment 2 Dafna Ron 2012-10-14 08:02:16 EDT
I tested again in si20. 

it reproduced. 

reproduce: 

1. create a domain. 
2. go to host -> iscsiadm -m node -u
3. go to UI -> storage -> edit domain

you can see that the lun appears as connected
Comment 3 Ayal Baron 2012-10-18 10:31:52 EDT
Looks like it's fixed in SI21, please verify
Comment 4 Dafna Ron 2012-10-21 02:50:00 EDT
it's not fixed in si21. 
This time it tool a long time for the edit domain dialogue to open and it showed an empty dialogue (probably because it did run discover on the host and found nothing) but, once I closed it it just kept appearing empty and the reply was too fast which suggests that we are not trying to discover again, and only after I moved between objects we sent the discover again.
Comment 5 Asaf Shakarchi 2012-10-22 04:57:11 EDT
Its not automatically triggering discovery, it only shows the attached devices, 
Did you get an empty dialog and you sure you had devices attached ?
Comment 6 Dafna Ron 2012-10-22 05:00:40 EDT
(In reply to comment #5)
> Its not automatically triggering discovery, it only shows the attached
> devices, 
> Did you get an empty dialog and you sure you had devices attached ?

yes
Comment 7 Asaf Shakarchi 2012-10-27 14:15:42 EDT
This is a total different behavior from the original cause of this bug,

I couldn't reproduce the new behavior as well, closing.

Note You need to log in before you can comment on or make changes to this bug.