Bug 846812 - Parsing errors generated on Revision_History.xml now do not specify the XML file/error
Parsing errors generated on Revision_History.xml now do not specify the XML f...
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: 3.0
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 15:21 EDT by Stephen Gordon
Modified: 2012-10-30 23:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 23:11:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2012-08-08 15:21:20 EDT
Description of problem:

When publican encounters a parsing error in the Revision_History.xml file, which is now parsed before the rest of the XML, the error doesn't specify what or where the problem is.

Mismatched firstname and/or surname tags caused the error in my case, but the only reason I realised this was because the only file I had changed was Revision_History.xml and it failed an xmllint when I ran it directly.

Version-Release number of selected component (if applicable):

publican-3.0-0.fc17.t216.noarch

Additional Information:

$ rhpkg publican build --langs=en-US --formats=html

mismatched tag at line 17, column 6, byte 565 at /usr/lib64/perl5/vendor_perl/XML/Parser.pm line 187
Comment 1 Ruediger Landmann 2012-08-15 02:33:23 EDT
Fix verified in build publican-3.0-0.fc17.t219.noarch:

Beginning work on en-US
DTD Validation failed: 
Revision_History.xml:8: validity error : Element revision is not declared in simpara list of possible children
Revision_History.xml:9: validity error : Element revision content does not follow the DTD, expecting (revnumber? , date , (author | authorinitials)* , (revremark | revdescription)?), got ()

Note You need to log in before you can comment on or make changes to this bug.