Bug 846837 - Error upgrading to current version of netsniff-ng-0.5.7-1.fc17.x86_64
Error upgrading to current version of netsniff-ng-0.5.7-1.fc17.x86_64
Status: CLOSED DUPLICATE of bug 842793
Product: Fedora
Classification: Fedora
Component: netsniff-ng (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 16:56 EDT by Michal Ambroz
Modified: 2012-08-09 05:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 05:58:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Ambroz 2012-08-08 16:56:32 EDT
Description of problem:
When trying to perform yum update, yum reports some error in the PREIN scriptlett.



Version-Release number of selected component (if applicable):
from netsniff-ng-0.5.6-2.fc17.x86_64
to   netsniff-ng-0.5.7-1.fc17.x86_64

How reproducible:
100%

Steps to Reproduce:
1. install version netsniff-ng-0.5.6-2.fc17.x86_64
2. yum -y update
3. see the error
  
Actual results:
Resolving Dependencies
--> Running transaction check
---> Package netsniff-ng.x86_64 0:0.5.6-2.fc17 will be updated
---> Package netsniff-ng.x86_64 0:0.5.7-1.fc17 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================================================================
 Package                                      Arch                                    Version                                        Repository                                Size
====================================================================================================================================================================================
Updating:
 netsniff-ng                                  x86_64                                  0.5.7-1.fc17                                   updates                                  297 k

Transaction Summary
====================================================================================================================================================================================
Upgrade  1 Package

Total download size: 297 k
Downloading Packages:
Setting up and reading Presto delta metadata
netsniff-ng-0.5.7-1.fc17.x86_64.rpm                                                                                                                          | 297 kB     00:00     
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Error in PREIN scriptlet in rpm package netsniff-ng-0.5.7-1.fc17.x86_64
error reading information on service netsniff-ng: No such file or directory
error: %pre(netsniff-ng-0.5.7-1.fc17.x86_64) scriptlet failed, exit status 1
netsniff-ng-0.5.6-2.fc17.x86_64 was supposed to be removed but is not!
  Verifying  : netsniff-ng-0.5.6-2.fc17.x86_64                                                                                                                                  1/2 
  Verifying  : netsniff-ng-0.5.7-1.fc17.x86_64                                                                                                                                  2/2 

Failed:
  netsniff-ng.x86_64 0:0.5.6-2.fc17                                                        netsniff-ng.x86_64 0:0.5.7-1.fc17                           

Expected results:
It is expected to upgrade to 0.5.7-1
Comment 1 Jaroslav Škarvada 2012-08-09 05:58:44 EDT
I think dupe of 842793, please try updated package (for f17):
https://admin.fedoraproject.org/updates/netsniff-ng-0.5.7-4.fc17
It shouldn't do that. Let me know if the problem persists.

*** This bug has been marked as a duplicate of bug 842793 ***

Note You need to log in before you can comment on or make changes to this bug.