Bug 846867 - [abrt] deluge-gtk-1.3.5-1.fc17: connectionmanager.py:481:on_button_connect_clicked:AttributeError: 'NoneType' object has no attribute 'addCallback'
[abrt] deluge-gtk-1.3.5-1.fc17: connectionmanager.py:481:on_button_connect_cl...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: deluge (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
abrt_hash:e90b588e313e20bb936abd78f90...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 20:35 EDT by Mengxuan Xia
Modified: 2013-02-20 21:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-20 21:01:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mengxuan Xia 2012-08-08 20:35:35 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python /usr/bin/deluge-gtk
executable:     /usr/bin/deluge-gtk
kernel:         3.5.0-2.fc17.x86_64
time:           2012年08月08日 星期三 20时32分51秒
uid:            1000
username:       xiamx

backtrace:
:connectionmanager.py:481:on_button_connect_clicked:AttributeError: 'NoneType' object has no attribute 'addCallback'
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/connectionmanager.py", line 578, in on_hostlist_row_activated
:    self.on_button_connect_clicked()
:  File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/connectionmanager.py", line 481, in on_button_connect_clicked
:    client.disconnect().addCallback(do_connect)
:AttributeError: 'NoneType' object has no attribute 'addCallback'
:
:Local variables in innermost frame:
:status: 'Offline'
:widget: None
:do_connect: <function do_connect at 0x2b87c08>
:port: 58846
:host: '192.168.1.175'
:model: <gtk.ListStore object at 0x2b960f0 (GtkListStore at 0x2d1f340)>
:self: <deluge.ui.gtkui.connectionmanager.ConnectionManager object at 0x2296cd0>
:row: <GtkTreeIter at 0x2dc55a0>
Comment 1 Ondra Pelech 2012-10-07 00:43:53 EDT
after trying to connect to the demon

Package: deluge-gtk-1.3.5-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 2 Calum 2013-02-20 21:01:10 EST
This is due to not restarting after disabling Classic Mode, fixed for next release: http://dev.deluge-torrent.org/ticket/1871

Note You need to log in before you can comment on or make changes to this bug.