Bug 846871 - NX remote desktop: login works but no panels appear
NX remote desktop: login works but no panels appear
Status: CLOSED DUPLICATE of bug 838028
Product: Fedora
Classification: Fedora
Component: nx (Show other bugs)
17
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 21:05 EDT by Robert K. Moniot
Modified: 2012-08-11 04:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-11 04:16:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert K. Moniot 2012-08-08 21:05:41 EDT
Description of problem:
Logging in from a remote NX client, no Gnome panels appear.  They are actually present but out of view.

Version-Release number of selected component (if applicable):
nx-3.5.0-11.fc17.x86_64


How reproducible: always


Steps to Reproduce:
1. Run nxserver on Fedora 17 Linux host, configured per instructions.
2. Run nx client on remote host.  (I find approx same behavior with client on Linux or Windows host.)  Select Gnome desktop.
3. Connect to Linux host.
  
Actual results:
Desktop background appears, but Gnome panels do not appear, or only partially appear.  Background image is enlarged so it does not all fit in viewport.

Expected results:
Should see desktop same as for console login, with panels etc.  It worked OK in Fedora 16.

Additional info:
The problem apparently is that the desktop is not fitting into the viewport.  Panels are present but off screen.  Dragging or panning does not work so one can't bring them into view.
Workaround: Using Ctrl-Alt-R to enter auto-resize mode brings the entire desktop into the viewport and returns things to normal operation.

I don't know if this problem is in nx server or Gnome desktop.  Probably the latter since KDE doesn't have this problem, at least for me.
Comment 1 Ville Skyttä 2012-08-11 04:16:06 EDT

*** This bug has been marked as a duplicate of bug 838028 ***

Note You need to log in before you can comment on or make changes to this bug.