Bug 846899 - Too many formal objects get ToC entries in PDF
Too many formal objects get ToC entries in PDF
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.0
Unspecified Unspecified
medium Severity medium
: 3.1
: ---
Assigned To: Jeff Fearn
tools-bugs
:
: 875519 875969 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 01:08 EDT by David O'Brien
Modified: 2015-09-27 22:35 EDT (History)
6 users (show)

See Also:
Fixed In Version: 3.1.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-05 22:40:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David O'Brien 2012-08-09 01:08:07 EDT
Description of problem:

The <subtitle> value appears as a child entry to <title> in the Nav Bar in pdf output.
Also true of authorgroup.

Version-Release number of selected component (if applicable):
3.0

How reproducible:
Probably always

Steps to Reproduce:
1. build a pdf book with <title> and <subtitle>
2. Inspect the TOC/Nav bar on the left
3.
  
Actual results:

"Subtitle" appears as a child of "Title". Apparently this is also the case with "Author Group" but we don't use this in OpenShift so I can't verify. Rudi noticed.

Expected results:

Neither should appear in the TOC or Nav Bar.

Additional info:
Comment 1 Ruediger Landmann 2012-08-09 02:24:34 EDT
Just to clarify; the TOC/Nav bar is the one presented in the PDF reader, not the website; issue presents in (at least) Okular, Evince, XPDF, and Adobe Reader.
Comment 3 Jeff Fearn 2012-11-07 00:53:46 EST
Dev note: check out --xsl-style-sheet option
Comment 4 Ruediger Landmann 2012-11-11 21:06:25 EST
*** Bug 875519 has been marked as a duplicate of this bug. ***
Comment 5 Ruediger Landmann 2012-11-12 19:54:07 EST
*** Bug 875969 has been marked as a duplicate of this bug. ***
Comment 6 Jeff Fearn 2013-01-14 01:54:27 EST
Changed usage from H to DIV where items where required.

This fix has been committed to the devel branch for inclusion in Publican 3.1.
Comment 7 xuezhi ma 2013-01-29 21:44:47 EST
Verify version: publican-3.1.0-0-el6eng.noarch -> PASS

Verify steps:
1. build a pdf book with <title> and <subtitle>
2. Inspect the TOC/Nav bar on the left

Actual results:
Title, subtitle and author group are appear in the TOC or Nav Bar.

Note You need to log in before you can comment on or make changes to this bug.