Bug 846920 - [virtio-win][scsi]System_reset guest while it is undergoing heavily pressure will lead to core dumped
[virtio-win][scsi]System_reset guest while it is undergoing heavily pressure ...
Status: CLOSED DUPLICATE of bug 805501
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 02:32 EDT by Min Deng
Modified: 2012-08-19 09:21 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-19 09:21:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The analysis of Core.930 (947 bytes, application/octet-stream)
2012-08-09 03:06 EDT, Min Deng
no flags Details

  None (edit)
Description Min Deng 2012-08-09 02:32:17 EDT
Description of problem:
Coredump occurred while system_reset guest which was undergoing heavily press.

Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-32

How reproducible:
100%
Steps to Reproduce:
1.boot up guest with the CLI
  /usr/libexec/qemu-kvm -m 2G -smp 4 -cpu cpu64-rhel6,+x2apic,family=0xf -usb -device usb-tablet -device virtio-scsi-pci,id=scsi0 -drive file=win7-32-scsi.qcow2,format=qcow2,if=none,id=drive-virtio0,cache=writeback,werror=stop,rerror=stop,serial=systemdisk -device scsi-hd,bus=scsi0.0,drive=drive-virtio0,id=virtio-blk-pci0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet0,mac=00:12:27:44:27:18 -uuid 57d734cb-bdf2-44d7-b750-9dff30e9d46b -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win732-scsi,server,nowait -mon chardev=111a,mode=readline -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=seabios_debug,path=/tmp/monitor-seabios,server,nowait -device isa-debugcon,iobase=0x402,chardev=seabios_debug -device virtio-scsi-pci,id=scsi1 -drive file=disk1.qcow2,if=none,format=qcow2,cache=writeback,id=drive-virtio-data1,werror=stop,rerror=stop,serial=disk1data -device scsi-hd,bus=scsi1.0,id=virtio-data1,drive=drive-virtio-data1 -device virtio-scsi-pci,id=scsi2 -drive file=disk2.qcow2,if=none,cache=writeback,format=qcow2,id=drive-virtio-data2,werror=stop,rerror=stop -device scsi-hd,bus=scsi2.0,id=virtio-data2,drive=drive-virtio-data2 -device virtio-scsi-pci,id=scsi3 -drive file=disk3.qcow2,cache=writethrough,if=none,format=qcow2,id=drive-virtio-data3,werror=stop,rerror=stop -device scsi-hd,bus=scsi3.0,id=virtio-data3,drive=drive-virtio-data3 -device virtio-scsi-pci,id=scsi4 -drive file=disk4.qcow2,if=none,format=qcow2,cache=writethrough,id=drive-virtio-data4,werror=stop,rerror=stop -device scsi-hd,bus=scsi4.0,id=virtio-data4,drive=drive-virtio-data4 -bios /usr/share/seabios/bios-pm.bin -spice port=5931,disable-ticketing -vga qxl -monitor stdio -qmp tcp:0:4444,server,nowait
2.please run multiple Crystal Disk Mark Apps on the five disks in order to give heavily press for the guest for reproducing
  Notes,the size of the guest image about 30G and each data disk about 2G. 
3.then do S4 (install qxl driver for the guest beforehand)
4.do system_reset from monitor 

Actual results:
Users can wake up guest,or via system_reset from monitor,the guest can reboot successfully
Expected results:
After system_reset,the guest became to black screen and at last,Core dumped happened.
-----------------------------------------------------------------------------
(qemu) system_reset
(qemu) Segmentation fault (core dumped)

Additional info:
Comment 1 Mike Cao 2012-08-09 02:34:58 EDT
This is a qemu-kvm bug ,move to the right component
Comment 4 Min Deng 2012-08-09 03:06:39 EDT
Created attachment 603186 [details]
The analysis of Core.930

The error log of core dump files via gdb
Comment 5 Paolo Bonzini 2012-08-19 09:21:14 EDT

*** This bug has been marked as a duplicate of bug 805501 ***

Note You need to log in before you can comment on or make changes to this bug.