Bug 846948 - Headpin cli contains the 'system_group' command but system_group along with its option is not supported by SAM
Headpin cli contains the 'system_group' command but system_group along with i...
Status: CLOSED NOTABUG
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Bryan Kearney
Tazim Kolhar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 04:31 EDT by Tazim Kolhar
Modified: 2016-04-25 20:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 09:53:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tazim Kolhar 2012-08-09 04:31:36 EDT
Description of problem:
The headpin deployment conatins system_group command which can be used via cli

Version-Release number of selected component (if applicable):

[root@dhcp201-197 script]# rpm -qa | grep katello
katello-cli-common-1.0.1-1.fc16.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-selinux-1.0.1-1.fc16.noarch
katello-configure-1.1.2-1.fc16.noarch
katello-common-1.1.4-1.fc16.noarch
katello-glue-pulp-1.1.4-1.fc16.noarch
katello-all-1.1.4-1.fc16.noarch
katello-glue-foreman-1.1.4-1.fc16.noarch
katello-1.1.4-1.fc16.noarch
katello-glue-candlepin-1.1.4-1.fc16.noarch
katello-certs-tools-1.1.7-1.fc16.noarch
katello-cli-1.0.1-1.fc16.noarch

How reproducible:

yum install -y katello-all thumbslug
katello-configure --deployment=headpin

Steps to Reproduce:
1.katello -u admin -p admin system_group --help

  
Actual results:
[root@dhcp201-197 script]# katello -u admin -p admin system_group --help
Usage:  katello <options> system_group <command>
Supported Commands:
	add_systems    add systems to a system group
	copy           Copy a system group
	create         create a system group
	delete         delete a system group
	errata         install errata on systems in a system group
	info           display a system group within an organization
	job_history    display the list of jobs for the specified system group.
	job_tasks      display job information including individual system tasks
	list           list system groups within an organization
	packages       manipulate the installed packages for systems in a system group
	remove_systems remove systems from a system group
	systems        display the systems in a system group
	update         update a system group

Options:
  -h, --help  show this help message and exit


Expected results:
This command should be discarded since it is not part of
SAM

Additional info:
Comment 1 Eric Sammons 2012-08-16 09:53:52 EDT
Remove katello-cli and add katello-cli-headpin and the issue should be resolved.

Note You need to log in before you can comment on or make changes to this bug.