Bug 846998 - Wrong folder ownership
Wrong folder ownership
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: p11-kit (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kalev Lember
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 08:12 EDT by Mario Blättermann
Modified: 2012-08-09 08:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 08:30:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Blättermann 2012-08-09 08:12:07 EDT
The spec file of pk11-kit contains the following line:

%doc %{_datadir}/gtk-doc/

This is bad, because this folder and the subfolder "html" (which is also owned by your package this way) is already owned by the gtk-doc package. Please change the line as follows:

%doc %{_datadir}/gtk-doc/html/*

and add gtk-doc as a runtime requirement to the -devel package.
Comment 1 Mario Blättermann 2012-08-09 08:30:13 EDT
Sorry for the blurb, just found the appropriate paragraph in the guidelines:
http://fedoraproject.org/wiki/Packaging:Guidelines#The_directory_is_owned_by_a_package_which_is_not_required_for_your_package_to_function

Note You need to log in before you can comment on or make changes to this bug.