Bug 847017 - os-prober: ERROR: unsupported sector size 4096 on /dev/sdd.
os-prober: ERROR: unsupported sector size 4096 on /dev/sdd.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: os-prober (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hedayat Vatankhah
Fedora Extras Quality Assurance
:
: 847013 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 09:17 EDT by John Ellson
Modified: 2012-08-10 08:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-10 08:45:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2012-08-09 09:17:15 EDT
Description of problem:
os-prober doesn't like WD 2TB USB3 external drives. grub2-mkconfig reports errors because of os-prober errors.

This problem was previously reported in BZ#743136 - but hasn't been fixed.

BZ#838305 reports that a new version of os-prober is available, but this hasn't reached f17 or rawhide yet.

I also noted the lack of man pages.  That also has been previously reported in BZ#826054


Version-Release number of selected component (if applicable):
os-prober-1.53-3.fc17.x86_64


How reproducible:
100%

Steps to Reproduce:
1. os-prober
2.
3.
  
Actual results:
ERROR: unsupported sector size 4096 on /dev/sdd.
ERROR: unsupported sector size 4096 on /dev/sdd.
ERROR: unsupported sector size 4096 on /dev/sdd.
ERROR: unsupported sector size 4096 on /dev/sdd.
ERROR: unsupported sector size 4096 on /dev/sdd.
ERROR: unsupported sector size 4096 on /dev/sdd.
ERROR: unsupported sector size 4096 on /dev/sdd.
ERROR: unsupported sector size 4096 on /dev/sdd.
ERROR: unsupported sector size 4096 on /dev/sdd.
ERROR: unsupported sector size 4096 on /dev/sdd.
/dev/mapper/vg_otherone-lv_root:Fedora release 16 (Verne):Fedora:linux


** don't know how it found F16 - the system is currently running F17
# uname -a
Linux otherone 3.5.0-2.fc17.x86_64 #1 SMP Mon Jul 30 14:48:59 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Expected results:
no errors

Additional info:
Comment 1 Hedayat Vatankhah 2012-08-09 13:56:30 EDT
*** Bug 847013 has been marked as a duplicate of this bug. ***
Comment 2 Hedayat Vatankhah 2012-08-09 14:15:57 EDT
Hi,
First, thank you for reporting the bug.
But there is no need to list all bugs related to a package when you report a bug, really! I'm aware of the other bug reports. 
The new version doesn't bring anything which worth an update, so it won't hit repos. 
 
Now, about your bug. It is hardly a bug with os-prober itself. Apparently, it is one of the tools which os-prober use which doesn't support 4K block sizes. It'd be nice if you can detect which program is generating the error. Unfortunately, i don't have such a device to test myself. You can use 'set -xv' in os-prober's shell scripts to find the command (look http://linux.101hacks.com/bash-scripting/debug-a-shell-script/).
Comment 3 John Ellson 2012-08-09 15:02:07 EDT
The message comes from the dmraid command in line #21


# dmraid -r -c
ERROR: unsupported sector size 4096 on /dev/sdd.
no raid disks


Another problem with the script, I think ... on this system I'm running Fedor-17, but os-prober is finding a Fedora-16 on some unmounted partition, and preferentially selecting that?

# os-mapper
...
/dev/mapper/vg_otherone-lv_root:Fedora release 16 (Verne):Fedora:linux


# mount
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime,seclabel)
devtmpfs on /dev type devtmpfs (rw,nosuid,seclabel,size=8174064k,nr_inodes=2043516,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,seclabel,gid=5,mode=620,ptmxmode=000)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev,seclabel)
tmpfs on /run type tmpfs (rw,nosuid,nodev,seclabel,mode=755)
/dev/sdb2 on / type ext4 (rw,relatime,seclabel,data=ordered)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
selinuxfs on /sys/fs/selinux type selinuxfs (rw,relatime)
tmpfs on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,seclabel,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/usr/lib/systemd/systemd-cgroups-agent,name=systemd)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct,cpu)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=26,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
mqueue on /dev/mqueue type mqueue (rw,relatime,seclabel)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
tmpfs on /media type tmpfs (rw,nosuid,nodev,noexec,relatime,seclabel,mode=755)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,seclabel)
configfs on /sys/kernel/config type configfs (rw,relatime)
/dev/sdb1 on /boot type ext4 (rw,relatime,seclabel,data=ordered)
/dev/sdb5 on /home type ext4 (rw,relatime,seclabel,data=ordered)
/dev/mapper/vg--otherone01-lv_libvirt_images on /var/lib/libvirt/images type ext4 (rw,relatime,seclabel,data=ordered)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
gvfs-fuse-daemon on /run/user/ellson/gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
/dev/sdd1 on /.private/.snapshots type ext4 (rw,relatime,seclabel,data=ordered)
Comment 4 Hedayat Vatankhah 2012-08-10 08:45:51 EDT
OK, so the error message is harmless (for os-prober). If dmraid should support 4K sector size, a bug/enhancement request should be filled against that. 

About showing Fedora 16 on another partition, that's fine. And os-prober does not "select" any OSes. It is actually designed to probe for "other" OSes. Grub already knows about your current OS with enough details (given in /etc/defaults/grub).

Closing this bug since it is not a bug. os-prober works just fine in your system.

Note You need to log in before you can comment on or make changes to this bug.