Bug 847020 - Creating bond, when both NICs have Network attached causes these networks to get detached (even when they can coexist on the same bond)
Creating bond, when both NICs have Network attached causes these networks to ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
medium Severity medium
: ---
: 3.2.0
Assigned To: Nobody's working on this, feel free to take it
Pavel Stehlik
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 09:22 EDT by GenadiC
Modified: 2016-02-10 14:49 EST (History)
11 users (show)

See Also:
Fixed In Version: sf4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 05:18:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sgrinber: Triaged+


Attachments (Terms of Use)
screenshot 1 (60.51 KB, image/png)
2012-10-22 10:04 EDT, Martin Pavlik
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10432 None None None Never

  None (edit)
Description GenadiC 2012-08-09 09:22:25 EDT
Description of problem:
If you create bond from NICs having Network that can coexist on the bond(for example to VLAN Networks) then the bond should be created with these 2 Networks, otherwise (Networks can't coexist on the same bond) the bond creation should fail with appropriate error message
This is related to bug 840825


Steps to Reproduce:
1. Create VLAN10 Network on NIC-A
2. Create VLAN20 Network on NIC-B
3. Try to create bond from NIC-A and NIC-B
  
Actual results:
The bond is created when both Networks are detached from the bond

Expected results:
The bond should be created with both networks attached to the bond
(In case you'll try to create bond from NICs that can't coexist, the error message should be displayed)

Additional info:
Comment 1 Martin Pavlik 2012-10-22 10:04:20 EDT
Regarding error message when trying to bond networks that cannot coexist on the same bond, it is displayed in dialog, but it is kind of hard to notice it due to the gray color of text. It might be a good idea to use different color (red maybe?) to make it easier to see for user.

Text of the message which is displayed now:
Networks on both interfaces : Detach all the networks from one of the interfaces/bond, if required re-attach to the bond

(see screenshot)
Comment 2 Martin Pavlik 2012-10-22 10:04:49 EDT
Created attachment 631568 [details]
screenshot 1
Comment 7 Martin Pavlik 2013-04-05 03:06:31 EDT
> If there are networks on both of the nics- error message should be displayed
> ("Networks on both interfaces : Detach all the networks from one of the
> interfaces/bond, if required re-attach to the bond").
> If there are networks just on one of the nics- bond with those networks
> should be created.

verified

in SF13 it works as described above, which is correct for now, it will be changed in the future
Comment 8 Itamar Heim 2013-06-11 05:18:56 EDT
3.2 has been released
Comment 9 Itamar Heim 2013-06-11 05:42:35 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.