Bug 847031 - SELinux is preventing /usr/lib/libreoffice/program/soffice.bin from 'create' accesses on the lnk_file 5023bc70d4cd1.
SELinux is preventing /usr/lib/libreoffice/program/soffice.bin from 'create' ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:696c5698f5322cca364ee16edb2...
:
: 847032 847034 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 09:46 EDT by drprcleary
Modified: 2012-08-10 05:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-10 05:50:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description drprcleary 2012-08-09 09:46:49 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.0-2.fc17.i686
time:           Thu 09 Aug 2012 02:45:48 PM BST

description:
:SELinux is preventing /usr/lib/libreoffice/program/soffice.bin from 'create' accesses on the lnk_file 5023bc70d4cd1.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that soffice.bin should be allowed create access on the 5023bc70d4cd1 lnk_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep soffice.bin /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:tmp_t:s0
:Target Objects                5023bc70d4cd1 [ lnk_file ]
:Source                        soffice.bin
:Source Path                   /usr/lib/libreoffice/program/soffice.bin
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           libreoffice-core-3.5.5.3-2.fc17.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-142.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.0-2.fc17.i686 #1 SMP Mon Jul 30
:                              15:41:00 UTC 2012 i686 i686
:Alert Count                   139
:First Seen                    Thu 09 Aug 2012 02:34:33 PM BST
:Last Seen                     Thu 09 Aug 2012 02:34:40 PM BST
:Local ID                      44f2c157-c7f3-480f-9cd2-d751cb14409c
:
:Raw Audit Messages
:type=AVC msg=audit(1344519280.870:2056): avc:  denied  { create } for  pid=28977 comm="soffice.bin" name="5023bc70d4cd1" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:tmp_t:s0 tclass=lnk_file
:
:
:type=SYSCALL msg=audit(1344519280.870:2056): arch=i386 syscall=symlink success=no exit=EACCES a0=b55a0d0c a1=b2e023c8 a2=afef22bc a3=b2e023c8 items=0 ppid=28941 pid=28977 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=1 comm=soffice.bin exe=/usr/lib/libreoffice/program/soffice.bin subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: soffice.bin,mozilla_plugin_t,tmp_t,lnk_file,create
:
:audit2allow
:
:#============= mozilla_plugin_t ==============
:allow mozilla_plugin_t tmp_t:lnk_file create;
:
:audit2allow -R
:
:#============= mozilla_plugin_t ==============
:allow mozilla_plugin_t tmp_t:lnk_file create;
:
Comment 1 Miroslav Grepl 2012-08-10 02:09:39 EDT
*** Bug 847032 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2012-08-10 02:09:43 EDT
*** Bug 847034 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2012-08-10 05:50:38 EDT
You need to either remove the mozplugger package or change the unconfined_mozilla_plugin_transition boolean

yum remove mozplugger

or

setsebool -P unconfined_mozilla_plugin_transition 0

Note You need to log in before you can comment on or make changes to this bug.