Bug 847037 - [RFE] Environment and organization names should be case insensitive i.e. Env and env and ENV should be treated as equals.
[RFE] Environment and organization names should be case insensitive i.e. Env ...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
x86_64 Linux
medium Severity medium (vote)
: Unspecified
: --
Assigned To: Jakub Hadvig
Katello QA List
: FutureFeature, TestBlocker, Triaged
Depends On: 844293
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 09:54 EDT by Eric Sammons
Modified: 2013-08-16 14:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 844293
Environment:
Last Closed: 2012-12-18 11:32:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sammons 2012-08-09 09:54:15 EDT
+++ This bug was initially created as a clone of Bug #844293 +++

Created attachment 601156 [details]
environment name validation

Description of problem:
A new environment similar to one already created is accepted in case the 
the names are derived from opposite cases (case insensitive)

Version-Release number of selected component (if applicable):
[root@nec-em16 ~]# rpm -qa | grep katello
katello-cli-common-0.2.45-1.fc16.noarch
katello-glue-foreman-0.2.50-1.fc16.noarch
katello-glue-pulp-0.2.50-1.fc16.noarch
katello-selinux-0.2.6-1.fc16.noarch
katello-certs-tools-1.1.6-1.fc16.noarch
katello-configure-0.2.32-1.fc16.noarch
katello-glue-candlepin-0.2.50-1.fc16.noarch
katello-all-0.2.53-1.fc16.noarch
katello-common-0.2.50-1.fc16.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-0.2.45-1.fc16.noarch
katello-0.2.50-1.fc16.noarch
katello-repos-0.2.7-1.fc16.noarch


How reproducible:
yum install -y katello-all thumbslug
katello-configure --deployment=headpin

Steps to Reproduce:
1.Log in to Server UI
2.Navigate Administer
3.Go to Manage Organisation
4.Click on the organisation
5.Add environment
6.Enter name same as one the already created environment
  but keep the case opposite (Upper case letters or Lower case letters)

Actual results:
No validation is done and the environment is created  

Expected results:
A validation should be provided 

Additional info:
screen shot attached
Comment 4 Tom McKay 2012-12-18 11:32:35 EST
working as designed
Comment 5 Mike McCune 2013-08-16 14:07:27 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.