Bug 847048 - Fix documentation regarding quiesce server option [NEEDINFO]
Fix documentation regarding quiesce server option
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Documentation-cluster (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: John Ha
ecs-bugs
: Documentation
Depends On: 847047
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 10:16 EDT by Ryan O'Hara
Modified: 2014-08-04 18:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 847047
Environment:
Last Closed: 2014-06-02 09:05:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (rohara)


Attachments (Terms of Use)

  None (edit)
Description Ryan O'Hara 2012-08-09 10:16:33 EDT
+++ This bug was initially created as a clone of Bug #847047 +++

The description of the 'quiesce server' option in the Load Balancer Administration document is incorrect and should be changes.

Specifically, the document contains two descriptions of the 'quiesce server' option that are incorrect:

- Section 1.3.2 states:

"To prevent this phenomenon, administrators can make the virtual server a quiesce server — anytime a new real server node comes online, the least-connections table is reset to zero and the LVS router routes requests as if all the real servers were newly added to the cluster."

- Section 4.6.1 states:

"When the Quiesce server radio button is selected, anytime a new real server node comes online, the least-connections table is reset to zero so the active LVS router routes requests as if all the real servers were freshly added to the pool. This option prevents the a new server from becoming bogged down with a high number of connections upon entering the pool."

Both of these statements are incorrect. The 'quiesce server' option will not reset the connection count and therefore does not avoid the "thundering herd" problem. The 'quiesce server' option determines how real servers are handled when determined to be unavailable.

- When a real server is determined to be unavailable and the 'quiesce server' option is disable, the failed real server will be removed from the IVPS. If the real server later becomes available, it will be added back to the virtual server table.

- When a real server is determined to be unavailable and the 'quiesce server' option is enabled, the real server will not be removed from the virtual server table. Instead its weight will be set to 0. This effectively disables the real server. If the real server later becomes available, the real servers will be re-enabled by restoring its weight.

From the ipvsadm(8) man page:

"Quiescent servers are specified with a weight of zero. A quiescent server will receive no new jobs but still serve the existing jobs, for all scheduling algorithms distributed with the Linux Virtual Server. Setting a quiescent server may be useful if the server is overloaded or needs to be taken out of service for maintenance."
Comment 1 Ryan O'Hara 2012-08-09 10:20:09 EDT
(In reply to comment #0)
> +++ This bug was initially created as a clone of Bug #847047 +++
> 
> The description of the 'quiesce server' option in the Load Balancer
> Administration document is incorrect and should be changes.

Actually, in RHEL5 the document is the Virtual Server Administration guide.
Comment 2 RHEL Product and Program Management 2014-03-07 08:36:46 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 3 RHEL Product and Program Management 2014-06-02 09:05:08 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.