Bug 847059 - Update of Fedora 17 packages impossible with yum
Update of Fedora 17 packages impossible with yum
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 10:49 EDT by Patrick Bonguardo
Modified: 2014-01-21 18:23 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-05 04:54:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error log (26.85 KB, text/plain)
2012-08-09 10:49 EDT, Patrick Bonguardo
no flags Details

  None (edit)
Description Patrick Bonguardo 2012-08-09 10:49:46 EDT
Created attachment 603271 [details]
Error log

Description of problem: 
Error when trying to update the Fedora 17 Packages with  yum groupupdate Base. Update impossible.


Version-Release number of selected component (if applicable): Fedora 17


How reproducible: always


Steps to Reproduce:
1. Login as root
2. yum update yum
3. yum clean all
4. yum groupupdate Base
  
Actual results: 
update fails with error messages (see log enclosed)
ERREUR lors de la vérification de la transaction avec les dépendances :


Expected results:
Updated packages

Additional info: see log enclosed
Comment 1 collura 2012-08-17 14:36:21 EDT
i might have a related issue where running yum seemed to crash system with 'memory manager error page_alloc.c: 796' (before preupgrded from fc16 to fc17 was 'page_alloc.c: 777') ?

since upgraded fc16->fc17 i wasnt able to get update due to system crashes but was able to downgrade and then update.

system stability seemed to improve when i was able to 

  yum clean all
  yum downgrade yum-*

which downgraded me 
from yum-0.3.4.3-28.fc17.x86_64
to yum-0.3.4.3-23.fc17.x86_64

then i could run updates normally ( though didnt update yum, will try if stability continues )

not sure this should have helped a page_alloc crash i had but i think a yum downgrade to yum-0.3.4.3-23.fc17.x86_64 fixed my issue so maybe help you.
Comment 2 Patrick Bonguardo 2012-08-20 13:14:05 EDT
(In reply to comment #1)
> i might have a related issue where running yum seemed to crash system with
> 'memory manager error page_alloc.c: 796' (before preupgrded from fc16 to
> fc17 was 'page_alloc.c: 777') ?
> 
> since upgraded fc16->fc17 i wasnt able to get update due to system crashes
> but was able to downgrade and then update.
> 
> system stability seemed to improve when i was able to 
> 
>   yum clean all
>   yum downgrade yum-*
> 
> which downgraded me 
> from yum-0.3.4.3-28.fc17.x86_64
> to yum-0.3.4.3-23.fc17.x86_64
> 
> then i could run updates normally ( though didnt update yum, will try if
> stability continues )
> 
> not sure this should have helped a page_alloc crash i had but i think a yum
> downgrade to yum-0.3.4.3-23.fc17.x86_64 fixed my issue so maybe help you.

Thank you, I tried to fix the problem with:

yum clean all
yum downgrade yum-*

Unfornunately, the downgrade of yum fails, with dependency problems (see below).


Test de la transaction en cours
ERREUR lors de la vérification de la transaction avec les dépendances :
python(abi) = 2.6 is needed by (installed) alchemist-1.0.37-8.fc12.x86_64
python(abi) = 2.6 is needed by (installed) bittorrent-4.4.0-14.fc13.noarch
python(abi) = 2.6 is needed by (installed) system-config-display-2.2-1.fc12.x86_64
python-abi = 2.6 is needed by (installed) alchemist-1.0.37-8.fc12.x86_64
Veuillez reporter cette erreur dans https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** 48 problèmes RPMDB préexistants trouvés, la sortie de « yum check » est la suivante :
...
Comment 3 Scott Lowrey 2012-09-04 13:02:41 EDT
For what it's worth, I had a similiar dependency issue with alchemist and python on my F16 system.  

If you look at the package names, you can see that the older Fedora packages are having problems.  If they aren't needed, you can simply remove them.

I did a "yum remove alchemist" (see bug 819323) and then my update worked.
Comment 4 Tim Lauridsen 2012-09-05 04:54:42 EDT
Look like you have some issue with some very old old packages (fc12 & fc13)
these packages is not compatible with the current packages, so you have to remove them and install something recent.

Remember upgrading from one release to another using yum is not supported.
It can be done, but you need to know how to solve package incompatibility issues.

This is not a problem with yum

Note You need to log in before you can comment on or make changes to this bug.