Bug 847060 - missing dependency for subscription-manager: pygobject2
missing dependency for subscription-manager: pygobject2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Linux
unspecified Severity low
: beta
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-08-09 10:51 EDT by chris.snyder
Modified: 2013-01-07 22:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:58:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chris.snyder 2012-08-09 10:51:06 EDT
Description of problem:

'subscription-manager' RPM is missing a dependency on the 'pygobject2' RPM.

Version-Release number of selected component (if applicable):

Was found on RHEL 5.8. 

Actual results:

After installing RHEL 5.8 via the graphical installer with a very tight, specific set of packages based up on our business needs, we found that 'subscription-manager' was installed (due to being a 'mandatory' install included with 'base' package group), but pygobject2 was *NOT* installed.
 
when /etc/cron.daily/rhsmd ran the first time, we received the following cron error:

/etc/cron.daily/rhsmd:

Traceback (most recent call last):
  File "/usr/libexec/rhsmd", line 21, in ?
    import gobject
ImportError: No module named gobject

It was determined that pygobject2 was never installed on the host as it never listed as an RPM dependency for the 'subscription-manager' RPM.  Once we added the package 'pygobject2', rhsmd ran without error.

Expected results:

All RPMs should have all dependencies defined. Specifically, in this case, the RPM 'subscription-manager' should list the RPM 'pygobject2' as as a dependency to ensure this package is installed.

Additional info:

Upon re-installing RHEL5.8 via the graphical installer, accepting *ALL* defaults with the exception of disabling SELinux, we found that pygobject2 was actually installed.  It appeared to have been installed as a dependency of the following packages, which were on the system:

[root@localhost ~]# rpm -q --whatrequires pygobject2
pygtk2-2.10.1-12.el5
yum-updatesd-0.9-2.el5
system-config-printer-0.7.32.10-1.el5_7.1
setroubleshoot-server-2.0.5-5.el5
gedit-2.16.0-9.el5

So it appears that under most situations, rhsmd probably works fine because pygobject2 was installed due to dependency linking with these other packages.  However, in our case, we didn't install any of those packages, but subscription-manager was still installed and we ended up not having pygobject2.

[root@localhost ~]# rpm -q subscription-manager
subscription-manager-0.98.14-1.el5
Comment 1 Bryan Kearney 2012-08-14 08:28:16 EDT
fixed in master at 61a277b49930a74ef37b302a4d767aa2f9926c66
Comment 2 RHEL Product and Program Management 2012-08-14 08:37:22 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 J.C. Molet 2012-08-22 09:57:39 EDT
python-rhsm-1.0.5-1.el5.x86_64.rpm            
subscription-manager-firstboot-1.0.14-1.el5.x86_64.rpm  
subscription-manager-migration-1.0.14-1.el5.x86_64.rpm
subscription-manager-1.0.14-1.el5.x86_64.rpm  
subscription-manager-gui-1.0.14-1.el5.x86_64.rpm        
subscription-manager-migration-data-1.11.2.3-1.el5.noarch.rpm

Testing with latest in brew ^^

As shown here, /usr/libexec/rhsmd is provided by subscription-manager:
[root@jmolet-vm0 brew]# rpm -qf /usr/libexec/rhsmd 
subscription-manager-1.0.14-1.el5

However, pygobject2 is now provided by subscription-manager-gui:
[root@jmolet-vm0 brew]# rpm -q --whatrequires pygobject2 | grep subscription
subscription-manager-gui-1.0.14-1.el5

This means that you could get in a situation where you can install subscription-manager without the gui and still run into this issue.

I'm throwing this one back so that the pygobject2 dependency can be moved to subscription-manager.
Comment 5 Bryan Kearney 2012-08-24 10:13:09 EDT
fixed in master at 91ecae876d772602d00ef509351ac7ca19802d83
Comment 6 Shwetha Kallesh 2012-09-18 08:50:05 EDT
Marking verified!!

[root@localhost ~]# rpm -qa | grep subscription-manager
subscription-manager-gui-1.0.18-1.el5
subscription-manager-firstboot-1.0.18-1.el5
subscription-manager-debuginfo-1.0.18-1.el5
subscription-manager-1.0.18-1.el5


[root@localhost ~]# rpm -qf /usr/libexec/rhsmd
subscription-manager-1.0.18-1.el5
[root@localhost ~]# rpm -q --whatrequires pygobject2 | grep subscription
subscription-manager-1.0.18-1.el5
Comment 8 errata-xmlrpc 2013-01-07 22:58:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.