Bug 847147 - 'read our User Guide topic on keys' is a dead link. on 3 Next Steps page after building a CakePHP Instant Application
'read our User Guide topic on keys' is a dead link. on 3 Next Steps page afte...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
: 847954 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 16:59 EDT by Dan Bailey
Modified: 2015-05-14 21:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:30:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Bailey 2012-08-09 16:59:06 EDT
Description of problem:  There is a dead User Guide link on the '3. Next Steps' page when building an application.

http://docs.redhat.com/docs/en-US/OpenShift/2.0/html/User_Guide/sect-User_Guide-Managing_SSH_Keys.html


Version-Release number of selected component (if applicable):


How reproducible:
Step 3 after building an application, there is a section that states "Set your Public Key 

Before you can upload code, you need to provide us with a public key to identify you to our servers. If this is your first time creating a public key read our User Guide topic on keys."  

The link tied to "read our User Guide topic on keys" is dead:

http://docs.redhat.com/docs/en-US/OpenShift/2.0/html/User_Guide/sect-User_Guide-Managing_SSH_Keys.html
Comment 1 Xiaoli Tian 2012-08-13 08:30:57 EDT
(In reply to comment #0)
> Description of problem:  There is a dead User Guide link on the '3. Next
> Steps' page when building an application.
> 
> http://docs.redhat.com/docs/en-US/OpenShift/2.0/html/User_Guide/sect-
> User_Guide-Managing_SSH_Keys.html
> 
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> Step 3 after building an application, there is a section that states "Set
> your Public Key 
> 
> Before you can upload code, you need to provide us with a public key to
> identify you to our servers. If this is your first time creating a public
> key read our User Guide topic on keys."  
> 
> The link tied to "read our User Guide topic on keys" is dead:
> 
> http://docs.redhat.com/docs/en-US/OpenShift/2.0/html/User_Guide/sect-
> User_Guide-Managing_SSH_Keys.html

The correct location should be http://docs.redhat.com/docs/en-US/OpenShift/2.0/html/User_Guide/sect-User_Guide-Managing_Your_OpenShift_Account-Managing_SSH_Keys.html

or link it to the baseurl: http://docs.redhat.com/docs/en-US/OpenShift/2.0/html/User_Guide/
Comment 2 David O'Brien 2012-08-13 20:20:42 EDT
Please don't deep link to Chapters or Sections. They're too susceptible to change in the current environment. Link to the base url for the book in question, on the NEW SITE, here:

https://access.redhat.com/knowledge/docs/OpenShift/
Comment 3 Mengjiao Gao 2012-08-14 04:08:39 EDT
*** Bug 847954 has been marked as a duplicate of this bug. ***
Comment 4 Clayton Coleman 2012-08-14 13:13:52 EDT
We've changed the links to the SSH stuff in the user guide and replaced them with links to the developer center.  I've also moved the "add an ssh key" block on the application get started page (after you create an app) up above the descriptive text so it is more obvious.  Finally, I've added additional help text to the SSH upload box so it is clearer what the content of the public key looks like.
Comment 5 Mengjiao Gao 2012-08-15 02:55:59 EDT
Tested this issue on devenv_1989, the link have been changed to "/community/developers/remote-access#keys" and the  "add an ssh key" block in the get started page have been moved up. So I will changed this issue to verified.
Comment 6 David O'Brien 2012-08-15 20:58:35 EDT
Clayton,
please update the relevant TA with details.

TA2687:	Update menu items to point to new doc site

Note You need to log in before you can comment on or make changes to this bug.