Bug 847251 - Nvidia Video driver, Panning is partially broken on main screen since last update to latest xorg-x11 via yum
Nvidia Video driver, Panning is partially broken on main screen since last up...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-10 05:43 EDT by Naipaul Ojar
Modified: 2012-08-29 11:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-29 11:53:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XSession Errors, I do not see any thing here .. (287.49 KB, text/plain)
2012-08-14 15:12 EDT, Naipaul Ojar
no flags Details
a combination of compressed files from /var/log (700.00 KB, application/x-tar)
2012-08-14 15:46 EDT, Naipaul Ojar
no flags Details
yum log with list of updated modules (210.54 KB, text/x-log)
2012-08-14 15:58 EDT, Naipaul Ojar
no flags Details

  None (edit)
Description Naipaul Ojar 2012-08-10 05:43:54 EDT
Description of problem:
I have F16 for my laptop machine, with both Twin-View and Panning on the "laptop screen" enabled and all has well for about 1 year. 
1. I performed a "yum update" and I found that xorg,conf - I believe was available as an update, and I accepted it. The Nvidia driver has not been upgraded for a while.
2. I got a new Logitech TrackBall mouse and I wanted to test it out so I rebooted my PC.
  - I placed the mouse in a USB 3.0 socket, my USB 2.0 was occupied by my phone.

Since that change my Panning, only configured on the laptop screen, is half-working.
Main laptop screen: 1920x1080 , with panning: 1920x1400

On restart, the PC would not go into graphical mode on the boot console, it hung there. I removed the Logitech mouse from the USB3.0 port and my laptop booted fine. After login:
    a. Its the first time that I have noticed the large Nvidia logo have a small RED "beta"  label at the bottom of it
    b. I found that the Gnome had started in fall-back mode and 
    c. The Desktop background only covered the "standard" part of the screen and not the 
        additional lower "panned" part of the screen.
    d. The "system Tray" and the external Disks, on my Docking Station all appear at the 
       bottom of the lower panned area
    e. Docky, set to "auto-hide", is activated at the bottom of the "standard" part of the 
       screen and not the additional lower "panned" part of the screen. This worked   
       previously prior to upgrade
    f. Trying to update the nvidia-settings now produces errors, stating that entries must 
       have unique names and some entry names are too long and I clicked the auto-repair


Remedies tried:-
1. I removed the xorg.conf entries for the Logitech Trackball mouse and logged out/in - no change
1. Saved the original xorg.conf file and copied over the contents from the xorg-nvidia.conf,  and restarted the machine, no change

Version-Release number of selected component (if applicable):
=============================================
rpm -qa *\nvidia\*  *\kernel\*  *xorg*|sort;uname -r;lsmod |grep -e nvidia -e nouveau;cat /etc/X11/xorg.conf
abrt-addon-kerneloops-2.0.7-3.fc16.x86_64
akmod-nvidia-304.32-2.fc16.x86_64
kernel-3.4.4-4.fc16.x86_64
kernel-3.4.6-1.fc16.x86_64
kernel-3.4.7-1.fc16.x86_64
kernel-devel-3.4.4-4.fc16.x86_64
kernel-devel-3.4.6-1.fc16.x86_64
kernel-devel-3.4.7-1.fc16.x86_64
kernel-headers-3.4.7-1.fc16.x86_64
kernel-tools-3.4.7-1.fc16.x86_64
kmod-nvidia-3.4.4-4.fc16.x86_64-304.32-2.fc16.x86_64
kmod-nvidia-3.4.6-1.fc16.x86_64-295.59-1.fc16.5.x86_64
kmod-nvidia-3.4.7-1.fc16.x86_64-304.32-2.fc16.x86_64
libreport-plugin-kerneloops-2.0.10-3.fc16.x86_64
nvidia-settings-1.0-17.fc16.x86_64
nvidia-xconfig-1.0-15.fc16.x86_64
xorg-x11-apps-7.6-2.fc15.x86_64
xorg-x11-drivers-7.4-2.fc15.x86_64
xorg-x11-drv-acecad-1.5.0-2.fc16.x86_64
xorg-x11-drv-aiptek-1.4.1-2.fc16.x86_64
xorg-x11-drv-apm-1.2.3-8.fc16.x86_64
xorg-x11-drv-ast-0.91.10-7.fc16.x86_64
xorg-x11-drv-ati-6.14.3-4.20120201git36c190671.fc16.x86_64
xorg-x11-drv-cirrus-1.3.2-10.fc16.x86_64
xorg-x11-drv-dummy-0.3.4-7.fc16.x86_64
xorg-x11-drv-elographics-1.3.0-2.fc16.x86_64
xorg-x11-drv-evdev-2.6.99.901-7.20120118git9d9c9870c.fc16.x86_64
xorg-x11-drv-fbdev-0.4.2-2.fc16.x86_64
xorg-x11-drv-fpit-1.4.0-2.fc16.x86_64
xorg-x11-drv-glint-1.2.5-2.fc16.x86_64
xorg-x11-drv-hyperpen-1.4.1-2.fc16.x86_64
xorg-x11-drv-i128-1.3.4-9.fc16.x86_64
xorg-x11-drv-i740-1.3.2-9.fc16.x86_64
xorg-x11-drv-intel-2.19.0-3.fc16.x86_64
xorg-x11-drv-keyboard-1.6.0-2.fc16.x86_64
xorg-x11-drv-mach64-6.9.0-2.fc16.x86_64
xorg-x11-drv-mga-1.4.13-8.fc16.x86_64
xorg-x11-drv-mouse-1.7.1-2.fc16.x86_64
xorg-x11-drv-mutouch-1.3.0-2.fc16.x86_64
xorg-x11-drv-nouveau-0.0.16-27.20110720gitb806e3f.fc16.x86_64
xorg-x11-drv-nv-2.1.18-8.fc16.x86_64
xorg-x11-drv-nvidia-304.32-1.fc16.x86_64
xorg-x11-drv-nvidia-libs-304.32-1.fc16.x86_64
xorg-x11-drv-openchrome-0.2.904-16.fc16.x86_64
xorg-x11-drv-penmount-1.5.0-3.fc16.x86_64
xorg-x11-drv-qxl-0.0.21-13.fc16.x86_64
xorg-x11-drv-r128-6.8.1-11.fc16.x86_64
xorg-x11-drv-rendition-4.2.4-7.fc16.x86_64
xorg-x11-drv-s3virge-1.10.4-9.fc16.x86_64
xorg-x11-drv-savage-2.3.3-1.fc16.x86_64
xorg-x11-drv-siliconmotion-1.7.5-2.fc16.x86_64
xorg-x11-drv-sis-0.10.3-7.fc16.x86_64
xorg-x11-drv-sisusb-0.9.4-7.fc16.x86_64
xorg-x11-drv-synaptics-1.5.0-2.fc16.x86_64
xorg-x11-drv-tdfx-1.4.3-9.fc16.x86_64
xorg-x11-drv-trident-1.3.4-7.fc16.x86_64
xorg-x11-drv-v4l-0.2.0-14.fc16.x86_64
xorg-x11-drv-vesa-2.3.0-9.fc16.x86_64
xorg-x11-drv-vmmouse-12.7.0-2.fc16.x86_64
xorg-x11-drv-vmware-11.0.3-6.fc16.x86_64
xorg-x11-drv-void-1.4.0-2.fc16.x86_64
xorg-x11-drv-voodoo-1.2.4-7.fc16.x86_64
xorg-x11-drv-wacom-0.12.0-1.fc16.x86_64
xorg-x11-fonts-100dpi-7.5-4.fc15.noarch
xorg-x11-fonts-ISO8859-1-100dpi-7.5-4.fc15.noarch
xorg-x11-fonts-ISO8859-14-100dpi-7.5-4.fc15.noarch
xorg-x11-fonts-ISO8859-14-75dpi-7.5-4.fc15.noarch
xorg-x11-fonts-ISO8859-15-100dpi-7.5-4.fc15.noarch
xorg-x11-fonts-ISO8859-15-75dpi-7.5-4.fc15.noarch
xorg-x11-fonts-ISO8859-1-75dpi-7.5-4.fc15.noarch
xorg-x11-fonts-misc-7.5-4.fc15.noarch
xorg-x11-fonts-truetype-1.0.2-1.fc16.noarch
xorg-x11-fonts-Type1-7.5-4.fc15.noarch
xorg-x11-font-utils-7.5-6.fc15.x86_64
xorg-x11-proto-devel-7.6-12.fc16.noarch
xorg-x11-resutils-7.5-2.fc15.x86_64
xorg-x11-server-common-1.11.4-3.fc16.x86_64
xorg-x11-server-utils-7.5-7.fc16.x86_64
xorg-x11-server-Xephyr-1.11.4-3.fc16.x86_64
xorg-x11-server-Xorg-1.11.4-3.fc16.x86_64
xorg-x11-utils-7.5-3.fc16.x86_64
xorg-x11-xauth-1.0.6-1.fc16.x86_64
xorg-x11-xinit-1.3.1-1.fc16.x86_64
xorg-x11-xkb-utils-7.5-5.fc16.x86_64
xorg-x11-xtrans-devel-1.2.6-2.fc15.noarch
3.4.7-1.fc16.x86_64
nvidia              11244331  45 
i2c_core               33895  3 nvidia,i2c_i801,videodev
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 295.49  (mockbuild@builder1.ovh.rpmfusion.lan)  Thu May  3 20:10:18 CEST 2012

# RPM Fusion - nvidia-xorg.conf
# 

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from data in "/etc/sysconfig/keyboard"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbLayout" "gb"
    Option         "XkbModel" "pc105"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection


Section "InputClass"
    Identifier "Marble Mouse"
    Driver "evdev"
    MatchProduct "Logitech USB Trackball"
    MatchDevicePath "/dev/input/event*"
    MatchIsPointer "yes"
    Option "ButtonMapping" "1 9 3 4 5 6 7 2 8"
    Option "EmulateWheel" "true"
    Option "EmulateWheelButton" "3"
    Option "ZAxisMapping" "4 5"
    Option "XAxisMapping" "6 7"
    Option "Emulate3Buttons" "false"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Lenovo Group Limited"
    HorizSync       56.5 - 67.8
    VertRefresh     50.0 - 60.0
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro 2000M"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Videocard0"
    Monitor        "Monitor0"
EndSection

Section "Screen"

# Removed Option "metamodes" "DFP-0: nvidia-auto-select @1920x1400 +0+0, CRT: nvidia-auto-select +1920+15"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DFP-0: 1920x1080 @1920x1400 +0+0, CRT: nvidia-auto-select +1920+15; DFP-0: nvidia-auto-select +0+0, CRT: nvidia-auto-select +1920+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


=============================================

How reproducible:


Steps to Reproduce:
1. Accept the yum update for xorg.conf - 2012-08-09
2. Reboot machine
3. Restart and login
  
Actual results:
a. Panning seems to be working for some non-X components
b. Not working for "Auto-Hide Docky" and the Desktop Wallpaper
c. The logical end of screen has not moved to end of the panned area, it is
   still at the end of the physical screen, with the panned area available but no desktop wall-paper - appears white.

Expected results:
a. To work prior to yum update.
b. The new logical end of primary screen should be the same as the end of the panned screen

Additional info:
Comment 1 Naipaul Ojar 2012-08-14 15:12:23 EDT
Created attachment 604410 [details]
XSession Errors, I do not see any thing here ..
Comment 2 Naipaul Ojar 2012-08-14 15:46:58 EDT
Created attachment 604429 [details]
a combination of compressed files from /var/log

cat messages | egrep -v "ll header:|IPv4:|FIREWALL:|DHCP|NetworkManager|vmnet|dhclient|offline" > messages_filtered
tar -cvf uploadLogs.tar Xorg.0.log.old.gz messages_filtered.gz Xorg.0.log
Comment 3 Naipaul Ojar 2012-08-14 15:58:47 EDT
Created attachment 604431 [details]
yum log with list of updated modules

This is the list of updates applied to the system.
Comment 4 Adam Jackson 2012-08-29 11:53:02 EDT
The NVIDIA driver is not supported by the Fedora project.

Note You need to log in before you can comment on or make changes to this bug.