Bug 847295 - Installation Guide review
Installation Guide review
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Docs Installation Guide (Show other bugs)
550
All Linux
low Severity low
: ---
: ---
Assigned To: Lana Brindley
ecs-bugs
:
Depends On:
Blocks: 826823
  Show dependency treegraph
 
Reported: 2012-08-10 09:29 EDT by Michael Mráka
Modified: 2013-10-23 19:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-25 23:22:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Mráka 2012-08-10 09:29:50 EDT
http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5
.5/html/Installation_Guide/sect-Installation_Guide-Summary_of_Steps.html

Maybe replace
        "Custom packages and channels require creation for optimal use."
with
        "Creation of custom channels for custom packages is recommended."

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5
.5/html/Installation_Guide/chap-Installation_Guide-Requirements.html

Chapter
        2.1. Software Requirements
        Satellite installation disc or ISO

Note should mention that server have to be subscribed to 'optional'
channel to be able to resolve package dependencies during installation
(or have packges from optional already installed).


http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5
.5/html/Installation_Guide/ch02s04s02.html

Typo
        "mandatory access control to Red Hat Enterprise LinuxRH; Enterprise Linu
x"
should be
        "mandatory access control to Red Hat Enterprise Linux"

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5
.5/html/Installation_Guide/sect-Installation_Guide-Additional_Requirements-DMZ_P
roxy_Solution.html


http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5
.5/html/Installation_Guide/sect-Installation_Guide-Additional_Requirements-Backu
ps.html

Do we really want to suggest
        "Red Hat strongly recommends this information be copied onto two
         separate floppy disks, ..."

? "Flash disk" or "usb memory stick" sounds more up-to-date ;).

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5
.5/html/Installation_Guide/sect-Installation_Guide-Additional_Requirements-Servi
ces.html

Text
        "The httpd service should be enabled."
should be replaced with
        "The folowing services should be enabled:
                * jabberd
                * oracle          (for Embedded Database Installation)
                * tomcat5         (for installation on RHEL5)
                * tomcat6         (for installation on RHEL6)
                * httpd
                * osa-dispatcher
                * Monitoring
                * MonitoringScout
                * rhn-search
                * cobblerd
                * taskomatic"

Also
        "...you must configure sendmail to properly handle incoming mail."
should be replaced with
        "...you must configure sendmail or postfix to properly handle incoming
          mail."
(Sendmail is default MTA on RHEL5, postfix is default on RHEL6.)


http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5
.5/html/Installation_Guide/chap-Installation_Guide-Installation.html
4.1.2. Mounting the Installation Media

Remove sentence
        "This section applies to either Stand-Alone Database or Embedded
         Database installation media."
because there's only one installation media for both Stand-Alone and Embedded
variant.


http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5
.5/html/Installation_Guide/sect-Installation_Guide-Installation-PreInstallation.
html
Table 4.1. Installation Options

Add
        "--external-db           install Stand-Alone Database variant".


http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5
.5/html/Installation_Guide/sect-Installation_Guide-Installation-Running_Installa
tion_Program.html
4.3.1. Runnning Installer Script

Should contain a Note:
        "To install RHN Satellite with a Stand-Alone Database use
         ./install.pl --external-db"


http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5
.5/html/Installation_Guide/sect-Installation_Guide-Installation-Running_Installa
tion_Program-Database_Setup.html
Stand-Alone Database

I'd again add a Note
        "To install RHN Satellite with a Stand-Alone Database use
         ./install.pl --external-db"


http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5
.5/html/Installation_Guide/sect-Installation_Guide-Installation-Sendmail_Configu
ration.html

Maybe we should rename it to "MTA Configuration" and move whole content
to a subsection called "Sendmail Configuration". And add one more
subsection with "Postfix Configuration" (similar steps just for
postfix).


http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5
.5/html/Installation_Guide/chap-Installation_Guide-Troubleshooting.html

Change URL in
        "contact Red Hat Network support at https://rhn.redhat.com/help/contact.
pxt"
to something more appropriate.


http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5
.5/html/Installation_Guide/chap-Installation_Guide-Troubleshooting.html
What do I do if yum, up2date, or the push capability of the RHN Satellite stops
working?

Replace
        service jabberd stop
        cd /var/lib/jabberd
        rm -f _db*
        service jabberd start
with
        service jabberd stop
        cd /var/lib/jabberd/db
        rm -f _db*
        service jabberd start
Comment 1 Dan Macpherson 2012-08-12 12:44:13 EDT
Implemented feedback - Committed SVN revision 84085.

Note You need to log in before you can comment on or make changes to this bug.