Bug 847437 - [abrt] ibus-1.4.99.20120712-1.fc17: main.py:268:__init_ui:AttributeError: 'NoneType' object has no attribute 'connect'
[abrt] ibus-1.4.99.20120712-1.fc17: main.py:268:__init_ui:AttributeError: 'No...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:fa1b18f29aca1e24a72d0086b67...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-11 05:13 EDT by lvucantsee
Modified: 2012-12-04 03:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 03:50:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lvucantsee 2012-08-11 05:13:33 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python /usr/share/ibus/setup/main.py
comment:        ibut input method
executable:     /usr/share/ibus/setup/main.py
kernel:         3.5.0-2.fc17.x86_64
time:           Sat 11 Aug 2012 05:12:49 PM CST
uid:            1000
username:       fuu.kn

backtrace:
:main.py:268:__init_ui:AttributeError: 'NoneType' object has no attribute 'connect'
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/setup/main.py", line 662, in <module>
:    setup = Setup()
:  File "/usr/share/ibus/setup/main.py", line 75, in __init__
:    self.__init_ui()
:  File "/usr/share/ibus/setup/main.py", line 268, in __init_ui
:    self.__config.connect("value-changed", self.__config_value_changed_cb)
:AttributeError: 'NoneType' object has no attribute 'connect'
:
:Local variables in innermost frame:
:self: <__main__.Setup object at 0x14b7950>
Comment 1 fujiwara 2012-08-13 21:46:12 EDT
(In reply to comment #0)
> :  File "/usr/share/ibus/setup/main.py", line 268, in __init_ui
> :    self.__config.connect("value-changed", self.__config_value_changed_cb)
> :AttributeError: 'NoneType' object has no attribute 'connect'


I guess this means /usr/libexec/ibus-dconf is not launched but I'm not sure why it could be happened.
Are you still able to reproduce the same error?
Comment 2 fujiwara 2012-12-04 03:50:41 EST
I cannot reproduce your problem.
If you see the problem again, please comment here.

Note You need to log in before you can comment on or make changes to this bug.