Bug 847599 - force the bootloader to be installed to the special disk when ondisk option is used in ksmeta
force the bootloader to be installed to the special disk when ondisk option i...
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: cobbler (Show other bugs)
15
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 01:40 EDT by Xiaowei Li
Modified: 2015-01-26 19:10 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 02:42:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaowei Li 2012-08-13 01:40:29 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. using this configuration: ks_meta="ondisk=/dev/disk/by-id/scsi-360a98000572d5765636f6b5658754a44" 
2. check the ks file created by cobbler
>>>
bootloader --location=mbr --append="kmemleak=on"
>>>
zerombr
clearpart --drives /dev/disk/by-id/scsi-360a98000572d5765636f6b5658754a44 --all --initlabel


part /boot --fstype ext3 --size 200 --recommended --ondisk=/dev/disk/by-id/scsi-360a98000572d5765636f6b5658754a44
part / --fstype ext3 --size 1024 --grow --asprimary --ondisk=/dev/disk/by-id/scsi-360a98000572d5765636f6b5658754a44
part swap --recommended --asprimary --ondisk=/dev/disk/by-id/scsi-360a98000572d5765636f6b5658754a44

  
Actual results:
bootloader --location=mbr --append="kmemleak=on"

Expected results:
bootloader --location=mbr --append="kmemleak=on" --driveorder = /dev/disk/by-id/scsi-360a98000572d5765636f6b5658754a44


Additional info:
Comment 1 Dan Callaghan 2012-08-13 01:53:00 EDT
I think you could use ks_meta="ignoredisk=--only-use=disk/by-id/scsi-360a98000572d5765636f6b5658754a44" instead. This is new in Beaker 0.9.2 (bug 840983). It will produce the following in the kickstart:

ignoredisk --only-use=disk/by-id/scsi-360a98000572d5765636f6b5658754a44

I think that should have the same effect as what you want. It seems like a cleaner solution than ondisk. Does it work for you?
Comment 2 Xiaowei Li 2012-08-13 02:06:14 EDT
(In reply to comment #1)
> I think you could use
> ks_meta="ignoredisk=--only-use=disk/by-id/scsi-
> 360a98000572d5765636f6b5658754a44" instead. This is new in Beaker 0.9.2 (bug
> 840983). It will produce the following in the kickstart:
> 
> ignoredisk --only-use=disk/by-id/scsi-360a98000572d5765636f6b5658754a44
> 
> I think that should have the same effect as what you want. It seems like a
> cleaner solution than ondisk. Does it work for you?

I am trying it. will update you later.
Comment 3 Xiaowei Li 2012-08-13 03:29:32 EDT
(In reply to comment #1)
> I think you could use
> ks_meta="ignoredisk=--only-use=disk/by-id/scsi-
> 360a98000572d5765636f6b5658754a44" instead. This is new in Beaker 0.9.2 (bug
> 840983). It will produce the following in the kickstart:
> 
> ignoredisk --only-use=disk/by-id/scsi-360a98000572d5765636f6b5658754a44
> 
> I think that should have the same effect as what you want. It seems like a
> cleaner solution than ondisk. Does it work for you?

It worked well. Nice work!

One question, if using the ignoredisk option the anaconda will use the LVM layout.
If i want to use the partition layout, not use LVM, how can i do?
Comment 4 Dan Callaghan 2012-08-16 02:42:22 EDT
(In reply to comment #3)
> One question, if using the ignoredisk option the anaconda will use the LVM
> layout.

That's because you are no longer using ondisk=, which means Beaker puts 'autopart' in the kickstart and so Anaconda has decided to use LVM.

> If i want to use the partition layout, not use LVM, how can i do?

You can define custom partitions in XML:

<partition name="/mnt/mypartition" size="10" type="ext4" />

If you want a custom partition layout in your kickstart but without any actual custom partitions, you can force Beaker to do that by passing ondisk like you were before. Then you will just have /, /boot, and swap but they won't be on LVM.

I'm going to close this bug as WONTFIX since I think ignoredisk --only-use is the proper solution here. If you need further help please ask on IRC or post to beaker-user-list.

Note You need to log in before you can comment on or make changes to this bug.