Bug 847602 - snapshot a block device record a incorrect backing file in snapshot if the device use relative path to file
snapshot a block device record a incorrect backing file in snapshot if the de...
Status: CLOSED DUPLICATE of bug 809140
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jeff Cody
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 01:55 EDT by xu
Modified: 2012-08-21 14:15 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-21 14:15:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xu 2012-08-13 01:55:42 EDT
Description of problem:
Incorrect backing file "actual path"recording in snapshot file if the device use a  relative path to file;

Version-Release number of selected component (if applicable):
qemu-img-rhev-0.12.1.2-2.302.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.302.el6.x86_64

How reproducible:


Steps to Reproduce:
1. start a guest with below cmdline:
qemu-kvm -cpu Penryn -smp 2,sockets=2,cores=1,threads=1 -m 4G -enable-kvm -uuid `uuidgen` -boot order=dcn,once=d -vnc :5 -k en-us -rtc base=localtime,driftfix=slew -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device usb-tablet,id=input0 -drive file=./rhel6.3.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,serial=yzWaibVh,cache=none,werror=stop,rerror=stop,aio=native -device ide-drive,drive=drive-virtio-disk0,id=virtio-disk0 -netdev tap,id=hostnet0,vhost=on -device virtio-net-pci,netdev=hostnet0,id=net0,mac=9a:1b:69:1a:e5:5c,bus=pci.0,addr=0x5,bootindex=3 -monitor stdio -device virtio-balloon-pci,id=balloon1,bus=pci.0,addr=0x7 -qmp tcp:localhost:4444,server,nowait

(-drive file=./rhel6.3.qcow2, use relative path to file)

2. executed "snapshot_blkdev drive-virtio-disk0 /tmp/sn1"

3. powerdown guest

4. qemu-img info /tmp/sn1

  
Actual results:

[root@localhost tmp]# qemu-img info /tmp/sn1
image: /tmp/sn1
file format: qcow2
virtual size: 60G (64424509440 bytes)
disk size: 136K
cluster_size: 65536
backing file: ./rhel6.3.qcow2 (actual path: /tmp/./rhel6.3.qcow2)

[root@localhost tmp]# locate rhel6.3.qcow2
/root/rhel6.3.qcow2

Expected results:

[root@localhost tmp]# qemu-img info /tmp/sn1
image: /tmp/sn1
file format: qcow2
virtual size: 60G (64424509440 bytes)
disk size: 136K
cluster_size: 65536
backing file: ./rhel6.3.qcow2 (actual path: /root/rhel6.3.qcow2)

Additional info:
Comment 2 Suqin Huang 2012-08-15 01:17:46 EDT
seems we need to use absolute path instead of relative path when boot guest.
Comment 3 Ademar Reis 2012-08-16 18:12:38 EDT
Related to, or even a duplicate of Bug 809140?
Comment 4 Jeff Cody 2012-08-21 14:15:52 EDT
It does indeed look like a duplicate of bug #809140

*** This bug has been marked as a duplicate of bug 809140 ***

Note You need to log in before you can comment on or make changes to this bug.