Bug 847616 - [scsi] qemu-kvm core dumped when (qemu)conti guest which is stopped due to EN_NOSPAC
[scsi] qemu-kvm core dumped when (qemu)conti guest which is stopped due to EN...
Status: CLOSED DUPLICATE of bug 808664
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Paolo Bonzini
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 03:17 EDT by Mike Cao
Modified: 2015-11-22 22:36 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-20 04:56:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Cao 2012-08-13 03:17:12 EDT
Description of problem:
start VM and dd files in / partition to make no space in '/' ,then guest will stop ,then (qemu)cont , core dumped will occurs  .

Version-Release number of selected component (if applicable):
# uname -r
2.6.32-294.el6.x86_64
[root@localhost /]#  rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.302.el6.x86_64
virtio-win-prewhql-32

How reproducible:
100%

Steps to Reproduce:
1.Start VM w/ virtio-scsi 
CLI:
#/usr/libexec/qemu-kvm -boot dc -m 4G -smp 2 -cpu Westmere -usb -device usb-tablet -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet2,mac=00:52:13:20:F5:22,bus=pci.0,addr=0x6 -uuid 7976cd92-6557-493d-86a3-7e2055a2d4cd -no-kvm-pit-reinjection -monitor stdio -rtc base=localtime,clock=host,driftfix=slew -device virtio-scsi-pci,id=bus1 -drive file=max.raw,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk0 -device scsi-disk,drive=scsi-disk0,id=disk,bus=bus1.0,serial=miketest -spice port=5910,disable-ticketing -vga qxl -fda /home/virtio-win.vfd -bios /usr/share/seabios/bios-pm.bin -drive file=/home/hotadd.qcow2,format=qcow2,id=drive-hotadd,serial=hotadd,cache=none,werror=stop,rerror=stop,if=none -device virtio-scsi-pci,id=hotaddscsi -device scsi-hd,drive=drive-hotadd,bus=bus1.0,id=tt1,logical_block_size=4096 -cdrom en_windows_server_2008_r2_standard_enterprise_datacenter_and_web_with_sp1_x64_dvd_617601.iso
2.during the same time , dd if=/dev/zero of=/tt on the host 
3.after guest stopped due to EN_NOSPAC ,press (qemu)cont 

Actual Results:
Core dump occurs 

Expected Results:
no core dump



Additional info :
qemu-kvm: /builddir/build/BUILD/qemu-kvm-0.12.1.2/hw/scsi-disk.c:366: scsi_write_data: Assertion `r->req.aiocb == ((void *)0)' failed.

Program received signal SIGABRT, Aborted.
0x00007ffff57788a5 in raise () from /lib64/libc.so.6

(gdb) bt
#0  0x00007ffff57788a5 in raise () from /lib64/libc.so.6
#1  0x00007ffff577a085 in abort () from /lib64/libc.so.6
#2  0x00007ffff5771a1e in __assert_fail_base () from /lib64/libc.so.6
#3  0x00007ffff5771ae0 in __assert_fail () from /lib64/libc.so.6
#4  0x00007ffff7e60201 in scsi_write_data (req=0x7fffe0011a40) at /usr/src/debug/qemu-kvm-0.12.1.2/hw/scsi-disk.c:366
#5  0x00007ffff7e5f7f6 in scsi_dma_restart_bh (opaque=<value optimized out>) at /usr/src/debug/qemu-kvm-0.12.1.2/hw/scsi-bus.c:53
#6  0x00007ffff7e1ec41 in qemu_bh_poll () at async.c:70
#7  0x00007ffff7dec629 in main_loop_wait (timeout=1000) at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:4032
#8  0x00007ffff7e0dd5a in kvm_main_loop () at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:2244
#9  0x00007ffff7deeffc in main_loop (argc=20, argv=<value optimized out>, envp=<value optimized out>) at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:4202
#10 main (argc=20, argv=<value optimized out>, envp=<value optimized out>) at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:6430
Comment 1 Ademar Reis 2012-08-16 18:16:55 EDT
From the backtrace, looks like a dupe of Bug 808664
Comment 2 Paolo Bonzini 2012-08-20 04:56:54 EDT

*** This bug has been marked as a duplicate of bug 808664 ***

Note You need to log in before you can comment on or make changes to this bug.