This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 847682 - internal error, aborting at reloc.c line 444 in bfd_get_reloc_size in /usr/bin/ld
internal error, aborting at reloc.c line 444 in bfd_get_reloc_size in /usr/bi...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nick Clifton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 05:32 EDT by Stef Walter
Modified: 2012-08-16 07:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 07:44:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stef Walter 2012-08-13 05:32:53 EDT
Description of problem:

ld aborts when building evolution with this error:

/usr/bin/ld: BFD version 2.23.51.0.1-1.fc18 20120806 internal error, aborting at reloc.c line 444 in bfd_get_reloc_size

libtool: install: (cd /data/src/jhbuild/evolution/mail; /bin/sh /data/src/jhbuild/evolution/libtool  --silent --tag CC --mode=relink gcc -g -O0 -fno-strict-aliasing -avoid-version -no-undefined -L/opt/build/lib64 -Wl,--no-undefined -o libevolution-mail.la -rpath /opt/build/lib64/evolution/3.6 libevolution_mail_la-e-http-request.lo libevolution_mail_la-e-mail-account-manager.lo libevolution_mail_la-e-mail-account-store.lo libevolution_mail_la-e-mail-account-tree-view.lo libevolution_mail_la-e-mail-autoconfig.lo libevolution_mail_la-e-mail-backend.lo libevolution_mail_la-e-mail-browser.lo libevolution_mail_la-e-mail-config-activity-page.lo libevolution_mail_la-e-mail-config-assistant.lo libevolution_mail_la-e-mail-config-auth-check.lo libevolution_mail_la-e-mail-config-confirm-page.lo libevolution_mail_la-e-mail-config-defaults-page.lo libevolution_mail_la-e-mail-config-identity-page.lo libevolution_mail_la-e-mail-config-lookup-page.lo libevolution_mail_la-e-mail-config-notebook.lo libevolution_mail_la-e-mail-config-page.lo libevolution_mail_la-e-mail-config-provider-page.lo libevolution_mail_la-e-mail-config-receiving-page.lo libevolution_mail_la-e-mail-config-security-page.lo libevolution_mail_la-e-mail-config-sending-page.lo libevolution_mail_la-e-mail-config-service-backend.lo libevolution_mail_la-e-mail-config-service-notebook.lo libevolution_mail_la-e-mail-config-service-page.lo libevolution_mail_la-e-mail-config-sidebar.lo libevolution_mail_la-e-mail-config-summary-page.lo libevolution_mail_la-e-mail-config-welcome-page.lo libevolution_mail_la-e-mail-config-window.lo libevolution_mail_la-e-mail-display.lo libevolution_mail_la-e-mail-display-popup-extension.lo libevolution_mail_la-e-mail-folder-pane.lo libevolution_mail_la-e-mail-junk-options.lo libevolution_mail_la-e-mail-label-action.lo libevolution_mail_la-e-mail-label-dialog.lo libevolution_mail_la-e-mail-label-list-store.lo libevolution_mail_la-e-mail-label-manager.lo libevolution_mail_la-e-mail-label-tree-view.lo libevolution_mail_la-e-mail-message-pane.lo libevolution_mail_la-e-mail-migrate.lo libevolution_mail_la-e-mail-notebook-view.lo libevolution_mail_la-e-mail-paned-view.lo libevolution_mail_la-e-mail-printer.lo libevolution_mail_la-e-mail-reader-utils.lo libevolution_mail_la-e-mail-reader.lo libevolution_mail_la-e-mail-request.lo libevolution_mail_la-e-mail-sidebar.lo libevolution_mail_la-e-mail-tag-editor.lo libevolution_mail_la-e-mail-ui-session.lo libevolution_mail_la-e-mail-view.lo libevolution_mail_la-em-composer-utils.lo libevolution_mail_la-em-config.lo libevolution_mail_la-em-event.lo libevolution_mail_la-em-filter-context.lo libevolution_mail_la-em-filter-editor.lo libevolution_mail_la-em-filter-editor-folder-element.lo libevolution_mail_la-em-filter-rule.lo libevolution_mail_la-em-filter-source-element.lo libevolution_mail_la-em-folder-properties.lo libevolution_mail_la-em-folder-selection-button.lo libevolution_mail_la-em-folder-selector.lo libevolution_mail_la-em-folder-tree-model.lo libevolution_mail_la-em-folder-tree.lo libevolution_mail_la-em-folder-utils.lo libevolution_mail_la-em-search-context.lo libevolution_mail_la-em-subscription-editor.lo libevolution_mail_la-em-utils.lo libevolution_mail_la-em-vfolder-editor-context.lo libevolution_mail_la-em-vfolder-editor-rule.lo libevolution_mail_la-em-vfolder-editor.lo libevolution_mail_la-mail-autofilter.lo libevolution_mail_la-mail-send-recv.lo libevolution_mail_la-mail-vfolder-ui.lo libevolution_mail_la-message-list.lo ../libemail-utils/libemail-utils.la ../libemail-engine/libemail-engine.la ../e-util/libeutil.la ../shell/libeshell.la ../composer/libcomposer.la ../widgets/table/libetable.la ../widgets/text/libetext.la ../widgets/menus/libmenus.la ../widgets/misc/libemiscwidgets.la ../widgets/menus/libmenus.la ../addressbook/gui/contact-editor/libecontacteditor.la ../addressbook/gui/contact-list-editor/libecontactlisteditor.la ../em-format/libemformat.la ../filter/libfilter.la ../libevolution-utils/libevolution-utils.la -Wl,--export-dynamic -pthread -L/opt/build/lib64 -lecal-1.2 -lical -licalss -licalvcal -ledataserverui-3.0 -lgtk-3 -lebook-1.2 -lgdk-3 -latk-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo-gobject -lpango-1.0 -lcairo -lebackend-1.2 -ledataserver-1.2 -lgmodule-2.0 -lrt -lcamel-1.2 -lgnome-keyring -lxml2 -lsoup-2.4 -lsqlite3 -lssl3 -lsmime3 -lnss3 -lnssutil3 -lplds4 -lplc4 -lnspr4 -lpthread -ldl -lgio-2.0 -lgobject-2.0 -lglib-2.0 -Wl,--export-dynamic -pthread -L/opt/build/lib64 -lgmodule-2.0 -lrt -lgailutil-3 -lxml2 -lgnome-desktop-3 -lwebkitgtk-3.0 -lgtk-3 -lsoup-2.4 -ljavascriptcoregtk-3.0 -lgdk-3 -latk-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo-gobject -lpango-1.0 -lcairo -lgio-2.0 -lgobject-2.0 -lglib-2.0 -lssl3 -lsmime3 -lnss3 -lnssutil3 -lplds4 -lplc4 -lnspr4 -lpthread -ldl -L/opt/build/lib64 -lcanberra-gtk3 -lcanberra -lgtk-3 -lgdk-3 -latk-1.0 -lgio-2.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo-gobject -lpango-1.0 -lcairo -lgobject-2.0 -lglib-2.0 -pthread -L/opt/build/lib64 -lgtkhtml-editor-4.0 -lgtkhtml-4.0 -lgtk-3 -lenchant -lgdk-3 -latk-1.0 -lgio-2.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo-gobject -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -lrt -lglib-2.0 ../smime/lib/libessmime.la ../smime/gui/libevolution-smime.la -L/opt/build/lib64 -lsoup-gnome-2.4 -lsoup-2.4 -lgio-2.0 -lgobject-2.0 -lglib-2.0 -lresolv )
/usr/bin/ld: BFD version 2.23.51.0.1-1.fc18 20120806 internal error, aborting at reloc.c line 444 in bfd_get_reloc_size

/usr/bin/ld: Please report this bug.

collect2: error: ld returned 1 exit status
libtool: install: error: relink `libevolution-mail.la' with the above command before installing it

Version-Release number of selected component (if applicable):

binutils-2.23.51.0.1-1.fc18.x86_64

How reproducible:

Every time.

Steps to Reproduce:
1. jhbuild build evolution
  
Actual results:

Fails to link during 'make install'

Expected results:

Install completes.
Comment 1 Nick Clifton 2012-08-14 07:21:02 EDT
Hi Stef,

  I need a way to reprouce this failure locally.  Is there any chance you could put together a compressed tarball of the objects and libraries shown in the error report above ?

Cheers
  Nick
Comment 2 Stef Walter 2012-08-16 07:44:28 EDT
I'll try and do that next time. Even though the problem was readily reproducible when I filed this report, I can no longer reproduce it.

Note You need to log in before you can comment on or make changes to this bug.