Bug 847724 - aeolus-configure -p mock,ec2 fails " "rake aborted! ...undefined method `find' for nil:NilClass""
aeolus-configure -p mock,ec2 fails " "rake aborted! ...undefined method `find...
Status: CLOSED DUPLICATE of bug 847373
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.1.0
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Mike Orazi
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 07:13 EDT by pushpesh sharma
Modified: 2014-08-04 18:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-13 09:55:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pushpesh sharma 2012-08-13 07:13:31 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Fresh F16 install.
2.  git clone git://github.com/aeolusproject/aeolus-cli.git
3.  git clone git://github.com/aeolusproject/aeolus-image-rubygem.git
4.  git clone git://github.com/aeolusproject/conductor.git
5.  git clone git://github.com/aeolusproject/aeolus-configure.git
6.  yum install vim screen make rubygem-rake rubygem-rspec-core
                rpm-build rubygem-sass rubygem-compass-960-plugin
                rubygem-rdoc deltacloud-core-all
7.  cd aeolus-cli; rake rpms; cd ..
8.  cd aeolus-configure; rake rpms; cd ..
9. cd aeolus-image-rubygem; rake rpms; cd ..
10. cd conductor; git submodule init && git submodule update;
      make rpms; cd ..
11. cd rpmbuild/RPMS/noarch; yum localinstall *rpm
12. aeolus-configure -p mock,ec2
  
Actual results:
Std o/p and Error

http://fpaste.org/tTLR/ 

Expected results:


Additional info:

[root@dhcp201-176 noarch]# rpm -qa|grep aeolus-
aeolus-configure-2.8.0-0.20120813091214git3dad5e9.fc16.noarch
aeolus-conductor-devel-0.13.0-0.20120813151251gite0b30a6.fc16.noarch
rubygem-aeolus-cli-0.7.0-0.20120813091204gitd64d64f.fc16.noarch
aeolus-conductor-0.13.0-0.20120813151251gite0b30a6.fc16.noarch
aeolus-conductor-doc-0.13.0-0.20120813151251gite0b30a6.fc16.noarch
aeolus-all-0.13.0-0.20120813151251gite0b30a6.fc16.noarch
aeolus-conductor-daemons-0.13.0-0.20120813151251gite0b30a6.fc16.noarch
rubygem-aeolus-image-0.6.0-0.20120813091222git25b7466.fc16.noarch
Comment 1 pushpesh sharma 2012-08-13 07:16:03 EDT

    [root@dhcp201-176 noarch]# aeolus-cleanup && aeolus-configure -p mock,ec2
    notice: /Stage[main]/Aeolus::Conductor::Disabled/Service[conductor-dbomatic]/ensure: ensure changed 'running' to 'stopped'
    notice: /Stage[main]/Aeolus::Image-factory::Disabled/Service[imagefactory]/ensure: ensure changed 'running' to 'stopped'
    notice: /Stage[main]/Aeolus::Image-factory::Disabled/Exec[remove_imagefactory_tmp_files]/returns: executed successfully
    notice: /Stage[main]/Aeolus::Iwhd::Disabled/Exec[clean_iwhd]/returns: Objects deleted: 0
    notice: /Stage[main]/Aeolus::Iwhd::Disabled/Exec[clean_iwhd]/returns: executed successfully
    notice: /Stage[main]/Aeolus::Iwhd::Disabled/Service[iwhd]/ensure: ensure changed 'running' to 'stopped'
    notice: /Stage[main]/Aeolus::Iwhd::Disabled/Service[mongod]/ensure: ensure changed 'running' to 'stopped'
    notice: /Stage[main]/Aeolus::Conductor::Disabled/Service[conductor-delayed_job]/ensure: ensure changed 'running' to 'stopped'
    notice: /Stage[main]/Aeolus::Conductor::Disabled/Service[aeolus-conductor]/ensure: ensure changed 'running' to 'stopped'
    notice: /Stage[main]/Aeolus::Conductor::Disabled/Aeolus::Rails::Drop::Db[drop_aeolus_database]/Exec[drop_rails_database]/returns: Using gem require instead of bundler
    notice: /Stage[main]/Aeolus::Conductor::Disabled/Aeolus::Rails::Drop::Db[drop_aeolus_database]/Exec[drop_rails_database]/returns: executed successfully
    notice: /Stage[main]/Aeolus::Conductor::Disabled/Postgres::User[aeolus]/Exec[drop_aeolus_postgres_user]/returns: executed successfully
    notice: /Stage[main]/Aeolus::Conductor::Disabled/Service[httpd]/ensure: ensure changed 'running' to 'stopped'
    notice: /Stage[main]/Aeolus::Image-factory::Disabled/Exec[remove_aeolus_templates]/returns: executed successfully
    notice: /Stage[main]/Aeolus::Deltacloud::Disabled/Service[deltacloud-core]/ensure: ensure changed 'running' to 'stopped'
    notice: /Stage[main]/Aeolus::Deltacloud::Disabled/Exec[remove_deltacloud_tmp_files]/returns: executed successfully
    notice: Finished catalog run in 15.30 seconds
    Launching aeolus configuration recipe...
    notice: /File[/etc/rsyslog.d/aeolus.conf]/ensure: defined content as '{md5}2d45434a072b4f9d1518ce026b92c547'
    notice: /File[/var/lib/aeolus-conductor]/ensure: created
    notice: /File[/usr/share/aeolus-conductor/config/initializers/secret_token.rb]/content: content changed '{md5}4065f1ed4b99c56c70e5782baaf36e53' to '{md5}10fcede63b3251da828241c22cc8e51c'
    notice: /Stage[main]/Apache/Service[httpd]/ensure: ensure changed 'stopped' to 'running'
    notice: /Stage[main]/Aeolus::Deltacloud::Core/Service[deltacloud-core]/ensure: ensure changed 'stopped' to 'running'
    notice: /Stage[main]/Aeolus::Deltacloud::Core/Exec[deltacloud-core-startup-wait]/returns: executed successfully
    notice: /Stage[main]/Aeolus::Conductor/Postgres::User[aeolus]/Exec[create_aeolus_postgres_user]/returns: executed successfully
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Rails::Create::Db[create_aeolus_database]/Exec[create_rails_database]/returns: Using gem require instead of bundler
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Rails::Create::Db[create_aeolus_database]/Exec[create_rails_database]/returns: executed successfully
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Rails::Migrate::Db[migrate_aeolus_database]/Exec[migrate_rails_database]/returns: executed successfully
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Rails::Seed::Db[seed_aeolus_database]/Exec[seed_rails_database]/returns: Using gem require instead of bundler
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Rails::Seed::Db[seed_aeolus_database]/Exec[seed_rails_database]/returns: executed successfully
    notice: /File[/var/lib/aeolus-conductor/production.seed]/ensure: created
    notice: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Temp_admin[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2]/Exec[create_temp_admin]/returns: rake aborted!
    notice: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Temp_admin[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2]/Exec[create_temp_admin]/returns: undefined method `find' for nil:NilClass
    notice: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Temp_admin[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2]/Exec[create_temp_admin]/returns:
    notice: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Temp_admin[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2]/Exec[create_temp_admin]/returns: Tasks: TOP => dc:create_user
    notice: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Temp_admin[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2]/Exec[create_temp_admin]/returns: (See full trace by running task with --trace)
    notice: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Temp_admin[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2]/Exec[create_temp_admin]/returns: Using gem require instead of bundler
    err: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Temp_admin[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2]/Exec[create_temp_admin]/returns: change from notrun to 0 failed: /usr/bin/rake dc:create_user[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2,f69f5b2a3e00a843a3ce64a94dfd1e190ba02f67c758c26a,'temp-admin@localhost.localdomain','temp','admin'] returned 1 instead of one of [0] at /usr/share/aeolus-configure/modules/aeolus/manifests/conductor/temp_admin.pp:7
    notice: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Temp_admin[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2]/Exec[grant_temp_admin_privs]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Temp_admin[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2]/Exec[grant_temp_admin_privs]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: rake aborted!
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: undefined method `find' for nil:NilClass
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns:
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: Tasks: TOP => dc:create_user
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: (See full trace by running task with --trace)
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: Using gem require instead of bundler
    err: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: change from notrun to 0 failed: /usr/bin/rake dc:create_user[admin,password,root@localhost.localdomain,Administrator,] returned 1 instead of one of [0] at /usr/share/aeolus-configure/modules/aeolus/manifests/conductor/site_admin.pp:9
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[grant_site_admin_privs]: Dependency Exec[create_site_admin_user] has failures: true
    warning: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[grant_site_admin_privs]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Conductor/Service[rsyslog]: Triggered 'refresh' from 1 events
    notice: /Stage[main]/Aeolus::Iwhd/Service[mongod]/ensure: ensure changed 'stopped' to 'running'
    notice: /Stage[main]/Aeolus::Iwhd/Service[iwhd]/ensure: ensure changed 'stopped' to 'running'
    notice: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Create_bucket[aeolus]/Exec[create-bucket-aeolus]/returns: % Total % Received % Xferd Average Speed Time Time Time Current
    notice: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Create_bucket[aeolus]/Exec[create-bucket-aeolus]/returns: Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0[create-bucket-aeolus]/returns:
    notice: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Create_bucket[aeolus]/Exec[create-bucket-aeolus]/returns: executed successfully
    notice: /Stage[main]/Aeolus::Conductor/Service[conductor-delayed_job]/ensure: ensure changed 'stopped' to 'running'
    notice: /Stage[main]/Aeolus::Conductor/Service[aeolus-conductor]/ensure: ensure changed 'stopped' to 'running'
    notice: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Login[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2]/Web_request[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2-conductor-login]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Login[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2]/Web_request[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2-conductor-login]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Login[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2]/Exec[decrement_login_counter]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Login[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2]/Exec[decrement_login_counter]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Hwp[small-x86_64]/Web_request[hwp-small-x86_64]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Hwp[small-x86_64]/Web_request[hwp-small-x86_64]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Provider[mock]/Web_request[provider-mock]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Provider[mock]/Web_request[provider-mock]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Provider::Account[mock]/Web_request[provider-account-mock]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Provider::Account[mock]/Web_request[provider-account-mock]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Logout[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2]/Web_request[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2-conductor-logout]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Logout[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2]/Web_request[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2-conductor-logout]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Destroy_temp_admin[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2]/Exec[destroy_temp_admin]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Mock/Aeolus::Conductor::Destroy_temp_admin[temporary-administrative-user-8222c790512dcc3f8073d798a38592d8f6ebd5644eccd2f2]/Exec[destroy_temp_admin]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Conductor/Service[conductor-dbomatic]/ensure: ensure changed 'stopped' to 'running'
    notice: /Stage[main]/Aeolus::Image-factory/File[/var/tmp/imagefactory-mock]/ensure: created
    notice: /Stage[main]/Aeolus::Image-factory/Service[imagefactory]/ensure: ensure changed 'stopped' to 'running'
    notice: Finished catalog run in 53.97 seconds
    notice: /Stage[main]/Aeolus::Deltacloud::Core/Exec[deltacloud-core-startup-wait]/returns: executed successfully
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Rails::Create::Db[create_aeolus_database]/Exec[create_rails_database]/returns: conductor already exists
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Rails::Create::Db[create_aeolus_database]/Exec[create_rails_database]/returns: Using gem require instead of bundler
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Rails::Create::Db[create_aeolus_database]/Exec[create_rails_database]/returns: executed successfully
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Rails::Migrate::Db[migrate_aeolus_database]/Exec[migrate_rails_database]/returns: executed successfully
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: rake aborted!
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: undefined method `find' for nil:NilClass
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns:
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: Tasks: TOP => dc:create_user
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: (See full trace by running task with --trace)
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: Using gem require instead of bundler
    err: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]/returns: change from notrun to 0 failed: /usr/bin/rake dc:create_user[admin,password,root@localhost.localdomain,Administrator,] returned 1 instead of one of [0] at /usr/share/aeolus-configure/modules/aeolus/manifests/conductor/site_admin.pp:9
    notice: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[grant_site_admin_privs]: Dependency Exec[create_site_admin_user] has failures: true
    warning: /Stage[main]/Aeolus::Conductor/Aeolus::Conductor::Site_admin[admin]/Exec[grant_site_admin_privs]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Temp_admin[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d]/Exec[create_temp_admin]/returns: rake aborted!
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Temp_admin[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d]/Exec[create_temp_admin]/returns: undefined method `find' for nil:NilClass
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Temp_admin[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d]/Exec[create_temp_admin]/returns:
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Temp_admin[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d]/Exec[create_temp_admin]/returns: Tasks: TOP => dc:create_user
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Temp_admin[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d]/Exec[create_temp_admin]/returns: (See full trace by running task with --trace)
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Temp_admin[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d]/Exec[create_temp_admin]/returns: Using gem require instead of bundler
    err: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Temp_admin[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d]/Exec[create_temp_admin]/returns: change from notrun to 0 failed: /usr/bin/rake dc:create_user[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d,a02dc5912b8f7367b703acb7ac3e1e1ed8832ca86c6061d6,'temp-admin@localhost.localdomain','temp','admin'] returned 1 instead of one of [0] at /usr/share/aeolus-configure/modules/aeolus/manifests/conductor/temp_admin.pp:7
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Temp_admin[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d]/Exec[grant_temp_admin_privs]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Temp_admin[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d]/Exec[grant_temp_admin_privs]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Login[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d]/Web_request[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d-conductor-login]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Login[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d]/Web_request[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d-conductor-login]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Login[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d]/Exec[decrement_login_counter]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Login[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d]/Exec[decrement_login_counter]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Provider[ec2-us-east-1]/Web_request[provider-ec2-us-east-1]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Provider[ec2-us-east-1]/Web_request[provider-ec2-us-east-1]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Provider[ec2-ap-southeast-1]/Web_request[provider-ec2-ap-southeast-1]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Provider[ec2-ap-southeast-1]/Web_request[provider-ec2-ap-southeast-1]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Hwp[small-x86_64]/Web_request[hwp-small-x86_64]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Hwp[small-x86_64]/Web_request[hwp-small-x86_64]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Provider[ec2-sa-east-1]/Web_request[provider-ec2-sa-east-1]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Provider[ec2-sa-east-1]/Web_request[provider-ec2-sa-east-1]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Provider[ec2-ap-northeast-1]/Web_request[provider-ec2-ap-northeast-1]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Provider[ec2-ap-northeast-1]/Web_request[provider-ec2-ap-northeast-1]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Provider[ec2-eu-west-1]/Web_request[provider-ec2-eu-west-1]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Provider[ec2-eu-west-1]/Web_request[provider-ec2-eu-west-1]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Provider[ec2-us-west-1]/Web_request[provider-ec2-us-west-1]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Provider[ec2-us-west-1]/Web_request[provider-ec2-us-west-1]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Provider[ec2-us-west-2]/Web_request[provider-ec2-us-west-2]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Provider[ec2-us-west-2]/Web_request[provider-ec2-us-west-2]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Logout[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d]/Web_request[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d-conductor-logout]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Logout[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d]/Web_request[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d-conductor-logout]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Destroy_temp_admin[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d]/Exec[destroy_temp_admin]: Dependency Exec[create_temp_admin] has failures: true
    warning: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Conductor::Destroy_temp_admin[temporary-administrative-user-4ff249cc75b00b4347419d4da9df24601c28d4523eaeb65d]/Exec[destroy_temp_admin]: Skipping because of failed dependencies
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Create_bucket[aeolus]/Exec[create-bucket-aeolus]/returns: % Total % Received % Xferd Average Speed Time Time Time Current
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Create_bucket[aeolus]/Exec[create-bucket-aeolus]/returns: Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0create-bucket-aeolus]/returns:
    notice: /Stage[main]/Aeolus::Profiles::Ec2/Aeolus::Create_bucket[aeolus]/Exec[create-bucket-aeolus]/returns: executed successfully
    notice: Finished catalog run in 19.64 seconds
Comment 2 pushpesh sharma 2012-08-13 09:55:36 EDT

*** This bug has been marked as a duplicate of bug 847373 ***

Note You need to log in before you can comment on or make changes to this bug.