Bug 847807 - ip_tables: REJECT target: only valid in filter table, not mangle
ip_tables: REJECT target: only valid in filter table, not mangle
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
18
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 11:42 EDT by Jiri Popelka
Modified: 2013-02-15 07:19 EST (History)
2 users (show)

See Also:
Fixed In Version: firewalld-0.2.9-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-15 07:19:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Popelka 2012-08-13 11:42:37 EDT
Version-Release number of selected component (if applicable):
firewalld-0.2.6-1.fc18.noarch
firewalld-0.2.7-1.fc18.noarch

Steps to Reproduce:
1. firewall-cmd --set-default-zone=block

Actual results:
Error: COMMAND_FAILED: '/sbin/iptables -A PREROUTING_ZONES -t mangle -i em1 -j REJECT --reject-with icmp-host-prohibited' failed: iptables: Invalid argument. Run `dmesg' for more information.

dmesg shows:
x_tables: ip_tables: REJECT target: only valid in filter table, not mangle


Neither iptables(8) nor Google tell me why REJECT target isn't valid but for example DROP seems to be valid.

Note You need to log in before you can comment on or make changes to this bug.