Bug 847812 - webadmin: when expending the disk under the storage -> vm's sub tab -> disk, the actual size is reported incorrectly
webadmin: when expending the disk under the storage -> vm's sub tab -> disk, ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: 3.1.0
Assigned To: Tal Nisan
Leonid Natapov
storage
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 11:52 EDT by Dafna Ron
Modified: 2016-02-10 14:12 EST (History)
10 users (show)

See Also:
Fixed In Version: SI19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:59:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (823.57 KB, application/x-gzip)
2012-08-13 11:52 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-08-13 11:52:52 EDT
Created attachment 604034 [details]
logs

Description of problem:

when expending the vm's disk under the storage tab -> select storage -> vm's tab -> expend disk, the size is reported incorrectly. 
in block device the actual size should always be equal to the virtual size. 

Version-Release number of selected component (if applicable):

si13.2

How reproducible:

100%

Steps to Reproduce:
1. create a vm with 10GB preallocated disk
2. go to storage tab -> select storage domain -> vm's sub tab -> expend the disk
3.
  
Actual results:

the disk which is unexpended is showing the correct virtual and actual size (which is 10GB) but when expanding the disk we are reporting virtual size as 10GB and actual size as 1GB 

Expected results:

in block device the actual size should always be equal to the virtual size. 

Additional info: screen shot + logs
Comment 1 Ayal Baron 2012-08-13 17:32:40 EDT
Dup of 847800?
Comment 2 Dafna Ron 2012-08-22 07:08:37 EDT
I'm not sure. 
it depends if the reason we are showing incorrect information on these two tabs is caused by the same issue which is something we need to check in the code. 
so basically this is your call... 

just once thing though, if indeed its the same issue, we just need to make sure that the bug closed as dup will have a comment for qe to check both locations when verifying :)
Comment 3 Tal Nisan 2012-09-19 12:06:10 EDT
http://gerrit.ovirt.org/#/c/8063/
Comment 5 Dafna Ron 2012-09-27 06:26:28 EDT
verified on si19

Note You need to log in before you can comment on or make changes to this bug.