Bug 847906 - Enable mod_deflate, mod_gzip on front-end Apache
Enable mod_deflate, mod_gzip on front-end Apache
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 21:03 EDT by Rob Millner
Modified: 2015-05-14 18:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:48:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Millner 2012-08-13 21:03:21 EDT
Request: from IRC thesteve0 on #openshift

Enable mod_deflate and mod_gzip on the front-end Apache for html, css, js, json, and xml mime types.
Comment 1 Steven Citron-Pousty 2012-08-13 21:04:39 EDT
It should be added to 000000_default.conf
In the reverse proxy layer
Comment 2 Rob Millner 2012-09-12 19:58:27 EDT
Li commit b4b9d7e adds the relevant changes to devenv.  Will be merged at the beginning of the next release.

This must be added to the release ticket for the next release.
Comment 3 Rob Millner 2012-09-17 17:27:16 EDT
Merged to master; waiting on a release ticket for 2.0.18 to complete.
Comment 4 Xiaoli Tian 2012-09-21 01:27:55 EDT
li pull request 369 has been merged since devenv_2177, move it to ON_QA to verify.
Comment 5 Jianwei Hou 2012-09-21 02:58:09 EDT
Verified on devenv_2209

Steps:
Launch instance and login, vim /etc/httpd/conf.d/000000_default.conf, check compression is enabled.

......
AddOutputFilterByType DEFLATE text/html text/plain application/xml text/xml text/css application/javascript text/javascript application/json text/json
......
Comment 6 Rob Millner 2012-09-21 20:03:40 EDT
This ticket is not resolved yet; requires update to the release ticket.
Comment 7 Rob Millner 2012-09-25 14:33:19 EDT
In the release ticket.
Comment 8 Rob Millner 2012-09-27 13:47:51 EDT
My solution relied on a deprecated command.  Do-over.
Comment 9 Rob Millner 2012-09-27 20:58:46 EDT
New pull request and comment added.

Note You need to log in before you can comment on or make changes to this bug.