Bug 847948 - Unable to compile oVirt frontend project in Eclipse Juno
Unable to compile oVirt frontend project in Eclipse Juno
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Build Subsystem (Show other bugs)
3.1.0
All All
unspecified Severity medium
: ---
: ---
Assigned To: Allon Mureinik
Yaniv Kaul
infra
: CodeChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 03:32 EDT by Allon Mureinik
Modified: 2016-02-10 14:05 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-27 07:10:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allon Mureinik 2012-08-14 03:32:31 EDT
Description of problem:
Importing the maven project into Eclipse Juno fails due to incomplete maven specification.

Version-Release number of selected component (if applicable):
oVirt: Change Id I720d2bb6f2d3a7f7dd228c5337f908b6deab0bb0
Eclipse: Juno (4.2)

How reproducible:
Import project into maven, as specified by Wiki documentation (http://ovirt.org/wiki/Building_Ovirt_Engine/IDE)

Steps to Reproduce:
See above
  
Actual results:
Eclipse error: "m2e is incompatible with..."

Expected results:
Project should be imported and compiled properly

Additional info:
Comment 1 Allon Mureinik 2012-08-14 03:36:19 EDT
Solved for oVirt at: http://gerrit.ovirt.org/#/c/6702 (merged).
Comment 4 Itamar Heim 2012-08-14 05:25:32 EDT
how is 6702 (webadmin: import block storage domains - fix refresh) related?
Comment 5 Allon Mureinik 2012-08-14 05:44:28 EDT
copy-paste bug, too many open windows.

The correct fix in oVirt is http://gerrit.ovirt.org/#/c/6834/ (core: Fixup Juno-Maven integration).
Comment 6 Allon Mureinik 2012-08-14 12:30:57 EDT
merged downstream: https://gerrit.eng.lab.tlv.redhat.com/#/c/1270/

Note You need to log in before you can comment on or make changes to this bug.