Bug 847974 - [Codechange]: Remove broken test MonitoringStrategyFactoryTest
[Codechange]: Remove broken test MonitoringStrategyFactoryTest
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Build Subsystem (Show other bugs)
3.1.0
All All
unspecified Severity medium
: ---
: ---
Assigned To: Allon Mureinik
Yaniv Kaul
infra
: CodeChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 05:01 EDT by Allon Mureinik
Modified: 2016-02-10 14:41 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-27 07:10:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 7123 None None None Never

  None (edit)
Description Allon Mureinik 2012-08-14 05:01:51 EDT
Description of problem:
This test is written wrong - it assumes a certain execution order by JUnit (which cannot be assumed) in order to run properly.
Currently, it consistently fails.

Since even if it worked properly it doesn't test any meaningful flow, and uses PowerMock which we're attempting to remove from the project, we wish to remove it, as was done in oVirt.

Version-Release number of selected component (if applicable):
The test breaks in Change-Id: Ifaa25bbaddad4c6894abfa3b9e83f205ee9678a1.

How reproducible:
100%

Steps to Reproduce:
1. Check out project
2. mvn clean install
  
Actual results:
MonitoringStrategyFactoryTest fails the build

Expected results:
The build should succeed.

Additional info:
Comment 1 Allon Mureinik 2012-08-14 05:06:12 EDT
Solution in oVirt was merged, pending acks to merge downstream:
http://gerrit.ovirt.org/#/c/7123/

Note You need to log in before you can comment on or make changes to this bug.