Bug 847982 - ovirt-engine-backend [Quota]: inconsistency in snapshot quota use calculations
ovirt-engine-backend [Quota]: inconsistency in snapshot quota use calculations
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: ofri
Dafna Ron
sla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 05:16 EDT by Dafna Ron
Modified: 2016-02-10 15:15 EST (History)
9 users (show)

See Also:
Fixed In Version: si17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot and log (98.47 KB, application/x-gzip)
2012-08-14 05:16 EDT, Dafna Ron
no flags Details
new log and screen shot (95.11 KB, application/x-gzip)
2012-08-14 05:24 EDT, Dafna Ron
no flags Details
log and screen shot (91.88 KB, application/x-gzip)
2012-09-02 07:56 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-08-14 05:16:49 EDT
Created attachment 604227 [details]
screen shot and log

Description of problem:

I added snapshot to a vm and while the storage calculation in quota shows that we are taking only 1GB per storage  I am getting an alert in event log. 
I also in quota enforce so I should have been blocked not just reported but was not. 

Version-Release number of selected component (if applicable):

si13.2

How reproducible:

100%

Steps to Reproduce:
1. create a quota with limitation on 30GB for one domain
2. create a vm with 5GB preallocated disk
3. start adding snapshots
  
Actual results:

I am getting an alert in event log on the 5th snapshot: 

Quota Dafna-si13-02 has exceeded Storage Threshold limitation.

Expected results:

1. if there was a quota violation and I'm in enforce I should be blocked
2. I can see in the quota that we are not exceeding and that each snapshot is calculated as 1 additional GB. 

Additional info: screen shot + log
Comment 1 Dafna Ron 2012-08-14 05:20:49 EDT
adding one one snapshot I was blocked by engine. 

Error:

Quota2:

    Cannot ${action} ${type}. Quota has no sufficient storage resources.

event log: 

Quota Dafna-si13-02 has exceeded Storage grace limitation.


it seems that we are calculating the snapshots as full size in engine but presenting it correctly in UI. 

adding new log and new screen shot
Comment 2 Dafna Ron 2012-08-14 05:24:37 EDT
Created attachment 604228 [details]
new log and screen shot
Comment 3 Doron Fediuck 2012-08-14 11:31:01 EDT
Dafna, can you make sure you weren't in the grace zone (which will only warn you)?

We're currently handling notifications in a different bz, but it sounds like you are not blocked sine you were given a grace.
Comment 4 Dafna Ron 2012-08-14 11:32:08 EDT
I was not :) I double checked before opening the bug
Comment 5 ofri 2012-08-21 02:49:13 EDT
Fixed on BZ#848028
Comment 6 Dafna Ron 2012-09-02 07:56:25 EDT
tested in si16
I was stopped after the fist snapshot
moving back to devel.
Comment 7 Dafna Ron 2012-09-02 07:56:47 EDT
Created attachment 609071 [details]
log and screen shot
Comment 8 Doron Fediuck 2012-09-02 08:24:37 EDT
Dafna,
what is the scenario you checked and when did it fail?
Comment 9 Dafna Ron 2012-09-02 08:41:22 EDT
same as described in bug's steps. 

Steps to Reproduce:
1. create a quota with limitation on 30GB for one domain
2. create a vm with 5GB preallocated disk
3. start adding snapshots
  

i was blocked after the first snapshot was created (so snapshot #2 failed).
Comment 10 ofri 2012-09-03 05:36:09 EDT
Fixed on BZ#848028 (New fix)
Comment 11 Dafna Ron 2012-09-09 14:15:01 EDT
I'm verifying this bug since most of the calculation errors are fixed with miner issues which are already specified in bug 848028 but there are no inconsistencies between backend and UI. 

verified on si17

Note You need to log in before you can comment on or make changes to this bug.