Bug 847987 - Missing check for vm required networks on run vm
Missing check for vm required networks on run vm
Status: CLOSED DUPLICATE of bug 841586
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Omer Frenkel
meital avital
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 05:30 EDT by Omer Frenkel
Modified: 2015-10-27 19:56 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-14 11:55:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Omer Frenkel 2012-08-14 05:30:42 EDT
Description of problem:
when running a vm with some networks,
but no host in the cluster has one of these networks,
the vm fails to run, but no error is produced to the user.

Version-Release number of selected component (if applicable):
3.1

How reproducible:
100%

Steps to Reproduce:
1. have vm with nic attached to a network, that no host is attached to
2. run vm.

Actual results:
vm fails to run, in the engine.log you can see:
2012-08-13 16:20:23,747 INFO  [org.ovirt.engine.core.bll.RunVmOnceCommand] (http--0.0.0.0-8080-1) [246a5f1a] Running command: RunVmOnceCommand internal: false. Entities affected :  ID: 79cd00f2-4098-4979-a38f-ef784d6a5766 Type: VM
2012-08-13 16:20:23,757 ERROR [org.ovirt.engine.core.bll.RunVmCommand] (http--0.0.0.0-8080-1) [246a5f1a] Cant find VDS to run the VM 79cd00f2-4098-4979-a38f-
ef784d6a5766 on, so this VM will not be run.
2012-08-13 16:20:23,774 ERROR [org.ovirt.engine.core.bll.RunVmOnceCommand] (http--0.0.0.0-8080-1) [246a5f1a] Transaction rolled-back for command: org.ovirt.engine.core.bll.RunVmOnceCommand.

Expected results:
User should get an error with explanation why the vm can't run (Can-Do-Action type of message as in other cases of lack of memory/cpu..)
Comment 1 Omer Frenkel 2012-08-14 06:26:18 EDT
http://gerrit.ovirt.org/#/c/7130/
Comment 3 meital avital 2012-08-14 11:55:59 EDT

*** This bug has been marked as a duplicate of bug 841586 ***

Note You need to log in before you can comment on or make changes to this bug.