Bug 847990 - the cursor should stay on the current setting if the input is invalid
the cursor should stay on the current setting if the input is invalid
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ovirt-node (Show other bugs)
7.1
Unspecified Unspecified
medium Severity low
: rc
: 7.0
Assigned To: Mike Burns
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 05:38 EDT by Mohua Li
Modified: 2016-04-26 12:18 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-05 02:08:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohua Li 2012-08-14 05:38:02 EDT
Description of problem:
for example, in TUI network page, when enter a invalid input, the cursor will jump to the next line, this is not expected, as the current setting didn't apply

Version-Release number of selected component (if applicable):            
rhev-hypervisor6-6.3-20120710.0.el6_3          

                           
How reproducible:                                                
100%                                                            


Steps to Reproduce:                                          
1.in TUI menu, choose network page
2.enter an invalid hostname then press "tab"
3.press "ok" on "configuration check" page
4.the cursor jump to next line "DNS server" instead stay on hostname line

Actual results:                                        
the cursor jump to next line "DNS server" instead stay on hostname line

Expected results:
the cursor need to stay on the current setting

  
Additional info:
this could happen to all pages, not sure if there is a global value to fix this, or need to go though each page,
Comment 8 wanghui 2013-07-04 22:52:14 EDT
The "configuration check" page is canceled in the latest rhev-hypervisor6-6.5-20130222.0.auto1707.el6.iso bulid.
So this time, when you input a invalid hostname, it will prompt you the error format your have inputed. And the curse will stay in there.
Suggest to close this bug since no such issue in latest bulid.
Comment 9 Ying Cui 2013-07-05 02:08:45 EDT
as comment 8, close this bug now, if we encounter such issue during 7.0 testing, we will reopen or submit new one.

Thanks
Ying

Note You need to log in before you can comment on or make changes to this bug.