Bug 847997 - RHEV-H upgrade failed in UEFI machine.
RHEV-H upgrade failed in UEFI machine.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 05:46 EDT by cshao
Modified: 2016-04-26 10:11 EDT (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-5.el6
Doc Type: Bug Fix
Doc Text:
An unmounted EFI partition caused a hypervisor upgrade to fail in an UEFI machine. This patch updates the grub configuration file path for UEFI upgrades, so upgrading the hypervisor succeeds as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:38:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
uefi upgrade (20.58 KB, image/jpeg)
2012-08-14 05:46 EDT, cshao
no flags Details
uefi upgrade failed (49.82 KB, image/jpeg)
2012-08-14 05:46 EDT, cshao
no flags Details
ovirt.log (114.48 KB, text/plain)
2012-08-14 05:47 EDT, cshao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0556 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2013-02-28 16:29:06 EST

  None (edit)
Description cshao 2012-08-14 05:46:00 EDT
Created attachment 604233 [details]
uefi upgrade

Description of problem:
RHEV-H upgrade failed in UEFI machine.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120813.0.el6_3

How reproducible:
100%

Steps to Reproduce:
1. Enter UEFI mode(Dell R510), install old RHEV-H version
 (e.g.rhev-hypervisor6-6.3-20120710.0.el6_3).
2. Upgrade RHEV-H to latest version (rhev-hypervisor6-6.3-20120813.0.el6_3) via livecd.
3. Input password and press continue button, focus on upgrade process.
  
Actual results:
1. RHEV-H upgrade failed in UEFI machine.
2. This did not happen in legacy mode.

Expected results:
RHEV-H upgrade can successful in UEFI machine.

Additional info:
Comment 1 cshao 2012-08-14 05:46:36 EDT
Created attachment 604234 [details]
uefi upgrade failed
Comment 2 cshao 2012-08-14 05:47:21 EDT
Created attachment 604235 [details]
ovirt.log
Comment 7 cshao 2012-10-31 04:30:27 EDT
Test version:
rhev-hypervisor6-6.4-20121015.1.el6.
ovirt-node-2.5.0-7.el6_4.noarch

Test setp:
1. Enter UEFI mode(Dell R510), install rhev-hypervisor6-6.4-20121015.1.el6.
2. Upgrade RHEV-H to rhev-hypervisor6-6.4-20121015.1.el6 via livecd.
  
Test results:
RHEV-H upgrade can successful in UEFI machine.

So the bug is fixed, change bug status to VERIFIED.
Comment 11 errata-xmlrpc 2013-02-28 11:38:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.