Bug 848163 - webadmin: 'Add Disk' dialog - 'Data Center' select-box is available in VM context
webadmin: 'Add Disk' dialog - 'Data Center' select-box is available in VM con...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
unspecified
Unspecified Unspecified
urgent Severity high
: ---
: 3.1.0
Assigned To: Daniel Erez
Haim
storage
:
: 854354 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 15:16 EDT by Daniel Erez
Modified: 2016-02-10 15:36 EST (History)
11 users (show)

See Also:
Fixed In Version: SI15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:00:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Erez 2012-08-14 15:16:30 EDT
Description of problem:
'Data Center' select-box is available when adding a disk in VM context,
i.e. 'Add' disk in Disks sub-tab (under VMs main-tab).
Consequently, 'Storage Domain' select-box is being filled according to the selected DC, instead of the VM's DC.

Version-Release number of selected component (if applicable):
SI14

How reproducible:
100%

Steps to Reproduce:
1. VMs main-tab -> select a VM.
2. Disks sub-tab -> 'Add' disk.
  
Actual results:
* 'Data Center' select-box is visible.
* 'Storage Domain' select-box is being filled according to the selected DC,
instead of the VM's DC.

Expected results:
* 'Data Center' select-box shouldn't be visible.
* 'Storage Domain' select-box should be filled according to the VM's DC.

Additional info:
When trying to add a disk on a wrong DC, the following error message is displayed - "Error while executing action: Cannot add Virtual Machine Disk. The target Data Center does not contain the Virtual Machine Disk."
Comment 3 Haim 2012-08-23 07:18:18 EDT
verified on si15. fix is according to requirement.
Comment 4 Itamar Heim 2012-09-04 14:43:13 EDT
*** Bug 854354 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.