Bug 848254 - marker logs "contribution node list is empty" while doing dbench.
marker logs "contribution node list is empty" while doing dbench.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
unspecified
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Raghavendra Bhat
Vijaykumar Koppad
:
Depends On: 829184
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 21:55 EDT by Vidya Sakar
Modified: 2014-08-24 20:49 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 829184
Environment:
Last Closed: 2013-09-23 18:33:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-08-14 21:55:40 EDT
+++ This bug was initially created as a clone of Bug #829184 +++

Description of problem:
while running dbench with options "-s -F -S --stat-check 10" seeing a lot warnings in brick log from marker saying  contribution node list is empty which is an error

[2012-06-06 07:15:27.675828] W [marker-quota.c:1284:mq_get_parent_inode_local] (-->/usr/local/lib/glusterfs/3.3git/xlator/performance/io-threads.so(iot_inodelk_cbk+0x158) [0x7fefcbbd90a0] (-->/usr/local/lib/libgl
usterfs.so.0(default_inodelk_cbk+0x158) [0x7fefd48f2f22] (-->/usr/local/lib/glusterfs/3.3git/xlator/features/marker.so(mq_inodelk_cbk+0x1d0) [0x7fefcb7af952]))) 0-colon-m-marker: contribution node list is empty w
hich is an error
[2012-06-06 07:15:27.676307] W [marker-quota.c:1284:mq_get_parent_inode_local] (-->/usr/local/lib/glusterfs/3.3git/xlator/performance/io-threads.so(iot_inodelk_cbk+0x158) [0x7fefcbbd90a0] (-->/usr/local/lib/libgl
usterfs.so.0(default_inodelk_cbk+0x158) [0x7fefd48f2f22] (-->/usr/local/lib/glusterfs/3.3git/xlator/features/marker.so(mq_inodelk_cbk+0x1d0) [0x7fefcb7af952]))) 0-colon-m-marker: contribution node list is empty w
hich is an error
[2012-06-06 07:15:27.676667] W [marker-quota.c:1284:mq_get_parent_inode_local] (-->/usr/local/lib/glusterfs/3.3git/xlator/performance/io-threads.so(iot_inodelk_cbk+0x158) [0x7fefcbbd90a0] (-->/usr/local/lib/libgl
usterfs.so.0(default_inodelk_cbk+0x158) [0x7fefd48f2f22] (-->/usr/local/lib/glusterfs/3.3git/xlator/features/marker.so(mq_inodelk_cbk+0x1d0) [0x7fefcb7af952]))) 0-colon-m-marker: contribution node list is empty w
hich is an error
[2012-06-06 07:15:27.677612] W [marker-quota.c:1284:mq_get_parent_inode_local] (-->/usr/local/lib/glusterfs/3.3git/xlator/performance/io-threads.so(iot_inodelk_cbk+0x158) [0x7fefcbbd90a0] (-->/usr/local/lib/libgl
usterfs.so.0(default_inodelk_cbk+0x158) [0x7fefd48f2f22] (-->/usr/local/lib/glusterfs/3.3git/xlator/features/marker.so(mq_inodelk_cbk+0x1d0) [0x7fefcb7af952]))) 0-colon-m-marker: contribution node list is empty w
hich is an error
[2012-06-06 07:15:27.677933] W [marker-quota.c:1284:mq_get_parent_inode_local] (-->/usr/local/lib/glusterfs/3.3git/xlator/performance/io-threads.so(iot_inodelk_cbk+0x158) [0x7fefcbbd90a0] (-->/usr/local/lib/libgl
usterfs.so.0(default_inodelk_cbk+0x158) [0x7fefd48f2f22] (-->/usr/local/lib/glusterfs/3.3git/xlator/features/marker.so(mq_inodelk_cbk+0x1d0) [0x7fefcb7af952]))) 0-colon-m-marker: contribution node list is empty w
hich is an error
[2012-06-06 07:15:27.678343] W [marker-quota.c:1284:mq_get_parent_inode_local] (-->/usr/local/lib/glusterfs/3.3git/xlator/performance/io-threads.so(iot_inodelk_cbk+0x158) [0x7fefcbbd90a0] (-->/usr/local/lib/libgl
usterfs.so.0(default_inodelk_cbk+0x158) [0x7fefd48f2f22] (-->/usr/local/lib/glusterfs/3.3git/xlator/features/marker.so(mq_inodelk_cbk+0x1d0) [0x7fefcb7af952]))) 0-colon-m-marker: contribution node list is empty w
hich is an error
[2012-06-06 07:15:27.678830] W [marker-quota.c:1284:mq_get_parent_inode_local] (-->/usr/local/lib/glusterfs/3.3git/xlator/performance/io-threads.so(iot_inodelk_cbk+0x158) [0x7fefcbbd90a0] (-->/usr/local/lib/libgl
usterfs.so.0(default_inodelk_cbk+0x158) [0x7fefd48f2f22] (-->/usr/local/lib/glusterfs/3.3git/xlator/features/marker.so(mq_inodelk_cbk+0x1d0) [0x7fefcb7af952]))) 0-colon-m-marker: contribution node list is empty w
hich is an error
[2012-06-06 07:15:27.690095] W [marker-quota.c:1284:mq_get_parent_inode_local] (-->/usr/local/lib/glusterfs/3.3git/xlator/performance/io-threads.so(iot_inodelk_cbk+0x158) [0x7fefcbbd90a0] (-->/usr/local/lib/libgl
usterfs.so.0(default_inodelk_cbk+0x158) [0x7fefd48f2f22] (-->/usr/local/lib/glusterfs/3.3git/xlator/features/marker.so(mq_inodelk_cbk+0x1d0) [0x7fefcb7af952]))) 0-colon-m-marker: contribution node list is empty w
hich is an error
[2012-06-06 07:15:27.690811] W [marker-quota.c:1284:mq_get_parent_inode_local] (-->/usr/local/lib/glusterfs/3.3git/xlator/performance/io-threads.so(iot_inodelk_cbk+0x158) [0x7fefcbbd90a0] (-->/usr/local/lib/libgl
usterfs.so.0(default_inodelk_cbk+0x158) [0x7fefd48f2f22] (-->/usr/local/lib/glusterfs/3.3git/xlator/features/marker.so(mq_inodelk_cbk+0x1d0) [0x7fefcb7af952]))) 0-colon-m-marker: contribution node list is empty w
hich is an error
[2012-06-06 07:15:27.691174] W [marker-quota.c:1284:mq_get_parent_inode_local] (-->/usr/local/lib/glusterfs/3.3git/xlator/performance/io-threads.so(iot_inodelk_cbk+0x158) [0x7fefcbbd90a0] (-->/usr/local/lib/libgl
usterfs.so.0(default_inodelk_cbk+0x158) [0x7fefd48f2f22] (-->/usr/local/lib/glusterfs/3.3git/xlator/features/marker.so(mq_inodelk_cbk+0x1d0) [0x7fefcb7af952]))) 0-colon-m-marker: contribution node list is empty w
hich is an error
[2012-06-06 07:15:27.691473] W [marker-quota.c:1284:mq_get_parent_inode_local] (-->/usr/local/lib/glusterfs/3.3git/xlator/performance/io-threads.so(iot_inodelk_cbk+0x158) [0x7fefcbbd90a0] (-->/usr/local/lib/libgl
usterfs.so.0(default_inodelk_cbk+0x158) [0x7fefd48f2f22] (-->/usr/local/lib/glusterfs/3.3git/xlator/features/marker.so(mq_inodelk_cbk+0x1d0) [0x7fefcb7af952]))) 0-colon-m-marker: contribution node list is empty w
hich is an error
[2012-06-06 07:15:27.692236] W [marker-quota.c:1284:mq_get_parent_inode_local] (-->/usr/local/lib/glusterfs/3.3git/xlator/performance/io-threads.so(iot_inodelk_cbk+0x158) [0x7fefcbbd90a0] (-->/usr/local/lib/libgl
usterfs.so.0(default_inodelk_cbk+0x158) [0x7fefd48f2f22] (-->/usr/local/lib/glusterfs/3.3git/xlator/features/marker.so(mq_inodelk_cbk+0x1d0) [0x7fefcb7af952]))) 0-colon-m-marker: contribution node list is empty w
hich is an error
[2012-06-06 07:15:27.692706] W [marker-quota.c:1284:mq_get_parent_inode_local] (-->/usr/local/lib/glusterfs/3.3git/xlator/performance/io-threads.so(iot_inodelk_cbk+0x158) [0x7fefcbbd90a0] (-->/usr/local/lib/libgl
:


Version-Release number of selected component (if applicable):Release-3.3
[c45d7ee5a9d45db1701a6a2490383484100c3aae]

How reproducible:consistently.


Steps to Reproduce:
1.Created a distributed replicate volume 3x2
2.enabled quota, gsync & stat-prefetch
3. ran dbench -s -F -S --stat-check 10 from single client

Actual results: Logs lot of warning in brick logs


Expected results: It should have clean logs.


Additional info:
Comment 2 Amar Tumballi 2012-10-18 01:57:11 EDT
 http://review.gluster.org/3935
Comment 3 Vijaykumar Koppad 2013-01-09 05:30:45 EST
Verified in glusterfs-3.4.0qa5-1.
Comment 5 Scott Haines 2013-09-23 18:33:04 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.