Bug 848287 - Can't do move for non-scalable app embed with mysql or mongodb
Can't do move for non-scalable app embed with mysql or mongodb
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 03:32 EDT by Rony Gong
Modified: 2015-05-14 18:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:29:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
move log from development.log (7.63 KB, text/plain)
2012-08-15 03:32 EDT, Rony Gong
no flags Details

  None (edit)
Description Rony Gong 2012-08-15 03:32:29 EDT
Created attachment 604525 [details]
move log from development.log

Description of problem:
when move non-scalable app embed with mysql, show error log like:

.  Output /usr/libexec/stickshift/cartridges/embedded/mysql-5.1/info/hooks/move: line 79: /var/lib/stickshift/35e551b673ff4b63bc5456ffc5c61b40//mysql-5.1/.env/OPENSHIFT_DB_PORT: No such file or directory\n", :data=>{:output=>"/usr/libexec/stickshift/cartridges/embedded/mysql-5.1/info/hooks/move: line 79: /var/lib/stickshift/35e551b673ff4b63bc5456ffc5c61b40//mysql-5.1/.env/OPENSHIFT_DB_PORT: No such file or directory\n", :exitcode=>1}, :sender=>"ip-10-122-51-233",


when move non-scalable app embed with mongodb, show error log like:

rpc_client.custom_request('cartridge_do', {:args=>"'qruby19' 'qgong2' '6d58e99209c240b98a64b917853fb823'", :action=>"move", :cartridge=>"embedded/mongodb-2.0"}, @id, {'identity' => @id})
DEBUG: [#<MCollective::RPC::Result:0x7f4a886dd4e8 @results={:statusmsg=>"cartridge_do_action failed 1.  Output /usr/libexec/stickshift/cartridges/embedded/mongodb-2.0/info/hooks/move: line 77: /var/lib/stickshift/6d58e99209c240b98a64b917853fb823//mongodb-2.0/.env/OPENSHIFT_NOSQL_DB_HOST: No such file or directory\n", :data=>{:output=>"/usr/libexec/stickshift/cartridges/embedded/mongodb-2.0/info/hooks/move: line 77: /var/lib/stickshift/6d58e99209c240b98a64b917853fb823//mongodb-2.0/.env/OPENSHIFT_NOSQL_DB_HOST: No such file or directory\n", :exitcode=>1}, :sender=>"ip-10-121-5-132", :statuscode=>1}, @action="cartridge_do", @agent="stickshift">]
DEBUG: server results: /usr/libexec/stickshift/cartridges/embedded/mongodb-2.0/info/hooks/move: line 77: /var/lib/stickshift/6d58e99209c240b98a64b917853fb823//mongodb-2.0/.env/OPENSHIFT_NOSQL_DB_HOST: No such file or directo



Version-Release number of selected component (if applicable):
devenv_1990

How reproducible:
always

Steps to Reproduce:

1.Create non-scalable app
2.Embed mysql  or mongodb-2.0
3.Do move by within district
rhc-admin-move --gear_uuid 35e551b673ff4b63bc5456ffc5c61b40 -i ip-10-122-51-233
  
Actual results:
Move fail, please see the attachment.

Expected results:
Move success.


Additional info:
Both mysql and mongodb need modify
Comment 1 Rony Gong 2012-08-15 04:04:32 EDT
This error also block move mysql gear in scalable app.

log:
DEBUG: Performing cartridge level move for embedded mysql-5.1 for 'qsphp' on ip-10-121-5-132
DEBUG: rpc_exec_direct: rpc_client=#<MCollective::RPC::Client:0x7fa6232c0b20>
DEBUG: rpc_client.custom_request('cartridge_do', {:args=>"'5bb219d085' 'qgong2' '5bb219d085e6485cad597430f6f2df47'", :action=>"move", :cartridge=>"embedded/mysql-5.1"}, @id, {'identity' => @id})
DEBUG: [#<MCollective::RPC::Result:0x7fa62325ae38 @results={:statusmsg=>"cartridge_do_action failed 1.  Output /usr/libexec/stickshift/cartridges/embedded/mysql-5.1/info/hooks/move: line 79: /var/lib/stickshift/5bb219d085e6485cad597430f6f2df47//mysql-5.1/.env/OPENSHIFT_DB_PORT: No such file or directory\n", :data=>{:output=>"/usr/libexec/stickshift/cartridges/embedded/mysql-5.1/info/hooks/move: line 79: /var/lib/stickshift/5bb219d085e6485cad597430f6f2df47//mysql-5.1/.env/OPENSHIFT_DB_PORT: No such file or directory\n", :exitcode=>1}, :sender=>"ip-10-121-5-132", :statuscode=>1}, @action="cartridge_do", @agent="stickshift">]
DEBUG: server results: /usr/libexec/stickshift/cartridges/embedded/mysql-5.1/info/hooks/move: line 79: /var/lib/stickshift/5bb219d085e6485cad597430f6f2df47//mysql-5.1/.env/OPENSHIFT_DB_PORT: No such file or directory
DEBUG: Cartridge command embedded/mysql-5.1::move exitcode = 1
DEBUG: server results: /usr/libexec/stickshift/cartridges/embedded/mysql-5.1/info/hooks/move: line 79: /var/lib/stickshift/5bb219d085e6485cad597430f6f2df47//mysql-5.1/.env/OPENSHIFT_DB_PORT: No such file or directory
DEBUG: Cartridge command embedded/mysql-5.1::move exitcode = 1
DEBUG: Moving failed.  Rolling back gear '5bb219d085' 'qsphp' with remove-httpd-proxy on 'ip-10-121-5-132'
DEBUG: Moving failed.  Rolling back gear '5bb219d085' in 'qsphp' with destroy on 'ip-10-121-5-132'

after rolling back, I found the mysql can't use any more:
[5bb219d085-qgong2.dev.rhcloud.com ~]\> mysql
ERROR 2003 (HY000): Can't connect to MySQL server on '127.1.246.1' (111)
Comment 2 Mrunal Patel 2012-08-15 11:31:46 EDT
From the logs, it looks like pre-move isn't getting called.
Comment 3 Mrunal Patel 2012-08-15 15:09:30 EDT
https://github.com/openshift/crankcase/pull/384
Comment 4 Rony Gong 2012-08-16 06:10:18 EDT
Verify on devenv_1997

Note You need to log in before you can comment on or make changes to this bug.