Bug 848303 - Here return error message for command "rhc-sshkey update -i key1"
Here return error message for command "rhc-sshkey update -i key1"
Status: CLOSED DUPLICATE of bug 842969
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
Depends On:
  Show dependency treegraph
Reported: 2012-08-15 04:46 EDT by Rony Gong
Modified: 2015-05-14 22:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-08-15 06:30:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rony Gong 2012-08-15 04:46:11 EDT
Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.type command: rhc-sshkey update -i key1 -d
Actual results:
[rony@localhost dev]$ rhc-sshkey update -i key1 -d

Generating ssh key pair for user 'key1' in the dir '/home/rony/mytest/dev/'
SSH key already exists: /home/rony/.ssh/id_rsa.  Reusing...
/usr/lib/ruby/gems/1.8/gems/rhc-0.97.6/lib/rhc-common.rb:1134:in `initialize': can't convert nil into String (TypeError)
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.97.6/lib/rhc-common.rb:1134:in `open'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.97.6/lib/rhc-common.rb:1134:in `add_or_update_key'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.97.6/bin/rhc-sshkey:162
	from /usr/bin/rhc-sshkey:19:in `load'
	from /usr/bin/rhc-sshkey:19

Expected results:
should print the usage help.

Additional info:
this error also happened for win7(ruby-1.9.3)
Comment 1 joycezhang 2012-08-15 06:30:25 EDT
This bug is duplicated with 842969. Thanks.

*** This bug has been marked as a duplicate of bug 842969 ***

Note You need to log in before you can comment on or make changes to this bug.